CPU/GPU efficiency for entry-level Ether mining on genesis launch?

deitrickdeitrick San DiegoMember Posts: 1
We've got a few weeks to go before the genesis block, and all signs point so far to CPU/GPU mining using a Linux Ubuntu or OS X system with AlethZero (unless I'm missing something). I'd like to be involved as a supporter and hobbyist but my primary computer is a laptop and I'm constantly on the move which is not ideal for staying online and processing. So, I've been toying with the idea of getting a linux desktop, raspberry pie(s) or other rig in order to participate. I'm not a developer, so I have to piggyback on the forums and youtube to get things set up.

1. Anyone have insight or guidelines as to what would be an optimum setup in terms of cost/efficiency?
2. Have Raspberry Pi test projects worked out?
3. If so, would the new Raspberry Pi 2 be suitable?
4. Or would just grabbing a Linux computer be easier/more efficient in terms of setup and processing power?

All best,



  • larzlarz Sussex, EnglandMember Posts: 17

    I guess a raspberry pi will struggle. Just not enough RAM. I've been playing a bit with trying to build ethereum on both a B+ and the new pi2. The B+ kept falling over when building boost 1.55 (despite a USB memory stick as swap space), whilst the pi2 happily compiles. Mine does fall over when trying to build ethereum though, and I haven't figured out why, so I can't tell you the actual hash rate, but I wouldn't expect much.
    Instead I've built ethereum on Ubuntu on a little Gigabyte Brix 4770R with 16GB. It does about 70KH/s vs the ~20KH/s that my core i5 MacBook Pro manages (both running poc8). Not sure whether that's good or bad.
  • PhonikGPhonikG Member Posts: 41 ✭✭
    True the RasPi 1B/1B+ will struggle somewhat, especially on the current testnet... They are definitely not suited for mining, but it will run a full node: http://ethembedded.com/?page_id=5

  • PhonikGPhonikG Member Posts: 41 ✭✭
    The current speed bump however is the heft of the testnet... and syncing...
  • vladin79vladin79 Member Posts: 4
    I followed the instructions here: http://ethembedded.com/?page_id=5 and successfully installed go-ethereum on Raspberry Pi 2. When I started geth, it successfully downloaded the blockchain. When I try to run it with --mine option in order to mine, it exits with the following error: "panic: ethash_full_new IO or memory error". I have set a 4GB swap file on the SD card, but it still gives the same error. Is there a way to successfully start mining on Raspberry Pi 2?
Sign In or Register to comment.