Why can't I ever synchronise?

o0ragman0oo0ragman0o Member, Moderator Posts: 1,291 mod
For weeks now I've been trying to work Frontier but it's just not happening anymore. Early on I figured it was just still bugs being worked out but now I have no idea.

The central problem is that I might get 256 blocks within 20 minutes at best but usually not at all. The last blocks downloaded over an hour ago but that's pretty useless when 256 blocks covers a time period of 50 minutes... At this rate, synchronisation is completely unfeasible. I haven't had a successful synch for over a week and the best block gets further away.

I'm currently connected to 12 peers. So that's not an issue.
Even though there's no console activity and no synching, geth is constantly writting to new blockchain and state files.

When I switch to verbosity 4 I can see what looks like streams of transactions being processed so I'm guessing geth validates every block that's synched. If so, why's it taking so long to do that?

At verbosity 5, I'm frequently seeing, "Synchronisation aborted: pending items in queue"

On top of that the blockchain is already over 12Gb in the short time of Frontier and ethereum hasn't even been released yet.
I've been following Etherum and currently I'm very disheartened with it and cannot see any feasibility in this technology if it's going to continue this kind of performance. :(

So if anyone can figure out anything wrong from the following, I'd be greatly appreciative.

Windows 7, Core 2 Quad, 4GB, GTX 750
geth 0.9.29

Have tried reinstalling geth through choco but only get:
"geth-latest not installed. The package was not found with the source(s) listed."
"geth-stable not installed. The package was not found with the source(s) listed."

I'm also having fails with ethcudaminer and gnl-ethminer. Have only managed one successful benchtest of my GTX 750 (6.6MH after 20 second warmup. 0 without) and only with OpenCL. Both miners currently crash instantly with the CUDA '-U' switch

Nvidia driver is 337.5 and CUDA packages are installed....

Sorry for the issues mashup in one post...just needed to get it out.


  • GeorgeHallamGeorgeHallam Member, Administrator, Moderator Posts: 229 admin
    edited June 2015
    Hey @o0ragman0o!

    Want to pm me your Skype addy (or add george_hallam) so I can add you to the Miner Community Support channel to get you some realtime assistance?

    In the mean time, I'll see if I can get an answer for your posted question on here.

    Edit: there are some PRs that fix sync issues and some are on the way right now (some are just out this morning, others in the next few hours). Are you on the latest develop branch? That will should help you solve the problem as well.
    Post edited by GeorgeHallam on
  • o0ragman0oo0ragman0o Member, Moderator Posts: 1,291 mod
    Thanks for the offer.
    I think I understand the issues now. They being insufficient healthy peers to propagate blocks because of the heavy processing toll of so many TX's while the network is being stress tested.

    I think the ethnetstat block prop graph says it all.
  • GenoilGenoil 0xeb9310b185455f863f526dab3d245809f6854b4dMember Posts: 769 ✭✭✭
    @o0ragman0o I understand your CUDA miner issues are now resolved, right? Note that the CUDA miner isn't officially supported by the dev team, you can messge me directly for support. Also, please do not attempt to mine with the binaries I dumped in the CUDA thread, I'm still ironing out bugs. For becnhmarking they should be ok though.

    I'm currently also trying to catch up with downloading the blockchain in order to give the CUDA miner a spin again. I only have like 10K to go but it is taking forever. Very frustrating indeed.
  • o0ragman0oo0ragman0o Member, Moderator Posts: 1,291 mod
    @Genoil, Ok I'll wait for something more formal then. Maybe you'll have a few versions down by the time I also synch ;) I haven't been able to get within 3000 blocks from best but blockchain performance seem to be picking up this evening so maybe by morning it'll all be good again.

    I've got some dedicated mining/development hardware coming in so should finally have a decent Linux box to hopefully keep more up to date on.
Sign In or Register to comment.