Lots of forks in the chain

Brillopad12Brillopad12 Member Posts: 17
Over the past 2 days I seem to be getting a lot more forks in the chain while mining. Twice they were big enough that I ended off the main chain and had to stop and reboot etc. Are they purposely trying to fork the chain now for the Olympic testing? Anything I can do to prevent it from happening or just keep checking the transactions? I am running GETH and ethminer on ubuntu.


  • jzenjzen Member Posts: 49
    what's the current best block number on the valid chain?
  • Brillopad12Brillopad12 Member Posts: 17
    Thanks @Wil611 that worked. However my copy of the chain couldn't sync back up. Apparently I had gotten too far off the track. I had to delete the chain. Any suggestions on how often to backup the chain to avoid having to redownload if this happens in the future?
  • StephanTualStephanTual London, EnglandMember, Moderator Posts: 1,282 mod
    @Billopad12: you won't have (and likely didn't have in this case either) have to delete and re-download the chain. Geth was updated, configured to detect the 'bad block' in question, ignore it and move on, without requiring a protocol change.

    It took a few git pushes before our devs had a fully working version, you probably were using one of the intermediary releases (the code on the devel branch is sometimes updated dozens of times per day).
  • oliverkxoliverkx Member Posts: 85
    Mining recap for the day - out of 3 machines, the first one synced, and has mined a few blocks, but it has been a constant struggle. The second one was initially able to sync, but hasn't mined a single block all evening (even though it has twice the hash power of the first machine). And the third machine never managed to sync at all.

    These results are with geth 0.9.30 on Windows 7, and using frequent manual restarts (every 15 minutes on average).

    I noticed that sometimes geth seems to be walking the block-chain backwards, or seems to be working on two chains at the same time (e.g. block 10, 20, 11, 21, 12, 22...).

    Also, the times of greatest instability seem to coincide with the presence of lots of transactions, which transpires from lots of messages in the form "including 179 txs in 2.1921254s. #624130 [8f41ec03 / 8f41ec03]". I sometimes wonder if having to include large numbers of transactions slows down enough machines on the network to create the appearance of a fork.
  • o0ragman0oo0ragman0o Member, Moderator Posts: 1,291 mod
    Nice to know I'm not the only one unable to attain sync...
  • Brillopad12Brillopad12 Member Posts: 17
    edited June 2015
    I have 3 nodes running also. 2 have been able to keep up but one can never seem to sync back up. It is running of 9.31 on OS X. One of my other machines is running the same however and doesn't seem to have an issue. I am trying the upgradedb option in GETH ATM is see if something got bugged in its chain. I wonder if it is similar to your windows issue since they are not as supported as Linux. My ubuntu box does every really seem to have an issue with GETH.
  • Brillopad12Brillopad12 Member Posts: 17
    The upgradeDB did not work...when it tried to reimport it said it was corrupted. I ended up removing the chain and I am redownloading it. It is working fine and syncing up quickly now. No idea how to prevent the chain from getting like that though. It seems that if it doesn't reorganize a chain correctly or then receives another fork in the midst of that reorganization it can lock it up and corrupt it.
Sign In or Register to comment.