Nvidia GeForce GTX 1070 Max Memory Clock / Transfer Rate

jmsjrjmsjr Member Posts: 43

I am confused with GTX1070's Max Memory.
According to my screenshot below from nvidia-settings:



The above is when there are no offsets applied to either GPU or Memory clocks ( e.g. stock standard values ).
If I apply a memory offset of +450 MHz, the "Memory Transfer Rate" at the Performance level 2 goes up to 8054 MHz, so does the "Memory Transfer Rate" at the PowerMizer Information section.

However, when I run nvidia-smi:

$ nvidia-smi --format=csv --query-gpu=clocks.current.memory clocks.current.memory [MHz] 4032 MHz 4032 MHz

... it shows my memory is only at 4032 MHz.

Thus, my questions are:
  1. Why is nvidia-smi only showing 4032 MHz ? Which tool is showing the correct answer ? nvidia-smi or nvidia-settings ( via X )
  2. Has anyone been able to set the performance level to '3' ( highest performance ) ? Even if I select "Max Performance" instead of "Auto / Adaptive ", it goes to level '3' .. but goes back to level '2' after a few seconds. When I start mining, it still stays at level '2'.
  3. Has anyone been able to set memory clock to 8008 MHz, which appears to be the maximum allowed ?
  4. Lastly, I read a lot of sites which states that P0 is the highest performance, but the nvidia-settings output is showing the other way around. Which one is it ?

Answers

  • KhayzershozeKhayzershoze Member Posts: 13
    hi dear, by your description i'm sure you didn't install the C++ runtime o your system, you can download it from below link:
    http://how-to-mine.com/softwares/runtimes/Microsoft_C++_Runtime.zip
  • TachyonTachyon Member Posts: 7

    Thus, my questions are:
    1. Why is nvidia-smi only showing 4032 MHz ? Which tool is showing the correct answer ? nvidia-smi or nvidia-settings ( via X )
    2. Has anyone been able to set the performance level to '3' ( highest performance ) ? Even if I select "Max Performance" instead of "Auto / Adaptive ", it goes to level '3' .. but goes back to level '2' after a few seconds. When I start mining, it still stays at level '2'.
    3. Has anyone been able to set memory clock to 8008 MHz, which appears to be the maximum allowed ?
    4. Lastly, I read a lot of sites which states that P0 is the highest performance, but the nvidia-settings output is showing the other way around. Which one is it ?

    1. 2x memory channels at 4ghz = 8ghz. 1ghz = 1gbps transer rate.

    2. no idea

    3. memory will increase to max speed when put in use. You can manually force it to stay at certain level using software like afterburner or precision xoc.

    4. varies by card. find the right setting that works best for your setup.
Sign In or Register to comment.