GPU mining with ethminer on NVIDIA

rachimo34rachimo34 Member Posts: 3
No matter what I do I have a Segmentation fault : 11 in result
Hardware: imac late 2013 GPU NVIDIA GeForce GTX 775M 2048 MB

$ eth -m on -G -M --opencl-platform 1 --opencl-device 1

Benchmarking on platform: { "platform": "Apple", "device": "GeForce GTX 775M", "version": "OpenCL 1.2 " }
Preparing DAG...
ℹ 17:10:50|main Loading from libethash...
ℹ 17:10:50|main Done loading.
ℹ 17:1Warming up...
0:50|gpuminer0 workLoop 0 #00000000… #00000000…
ℹ 17:10:50|gpuminer0 Initialising miner...
Using platform: Apple
Using device: GeForce GTX 775M(OpenCL 1.2 )
Trial 1...Segmentation fault: 11

It doesn't matter which opencl device or platform I select.
Anyone have an idea what can be wrong?

Comments

  • rachimo34rachimo34 Member Posts: 3
    found the problem, it was related with cmake -DETHASHCL=1
    I had to re-install the ethminer from scratch and somehow its worked.
  • BripsBrips Member Posts: 52
    edited May 2015
    Hello,
    With a GTX 970 card, i can run the bench mark (and having 11.9MHs for inner mean) but when i try to mine on Olympic with eth i've got systematically a core dumped

    ℹ 19:19:14|eth Restarting mining...
    ⧎ ℹ 19:19:14|p2p|4beba5e2…|++eth/v0.9.23/Release/Linux/g++/int Finishing blocks fetch...
    ⧎ ℹ 19:19:14|p2p|4beba5e2…|++eth/v0.9.23/Release/Linux/g++/int Chain download complete.
    ⧎ ℹ 19:19:14|p2p|4beba5e2…|++eth/v0.9.23/Release/Linux/g++/int No more peers to sync with.
    ℹ 19:19:14|gpuminer0 Awaiting DAG
    ℹ 19:19:15|gpuminer0 Awaiting DAG
    ℹ 19:19:15|gpuminer0 Awaiting DAG
    ℹ 19:19:16|gpuminer0 Awaiting DAG
    ℹ 19:19:16|gpuminer0 Awaiting DAG
    ℹ 19:19:17|gpuminer0 Awaiting DAG
    ℹ 19:19:17|gpuminer0 workLoop 1 #526ee6e6… #526ee6e6…
    Press EnterErreur de segmentation (core dumped)
  • tinuxjetinuxje Member Posts: 1
    edited May 2015
    Hello,

    I am trying to mine on my Imac but get this warning.

    Error GPU mining: clEnqueueNDRangeKernel ( -4 )

    I have no clue what it means.

    Anybody can help me out?

    eth -m on -G -M --opencl-platform 1 --opencl-device 1
    Benchmarking on platform: { "platform": "Apple", "device": "GeForce GT 755M", "version": "OpenCL 1.2 " }
    Preparing DAG...
    Warming up...
    ℹ 14:10:34|gpuminer0 workLoop 0 #00000000… #00000000…
    ℹ 14:10:34|gpuminer0 Initialising miner...
    Using platform: Apple
    Using device: GeForce GT 755M(OpenCL 1.2 )
    ✘ 14:10:36|gpuminer0 Error GPU mining: clEnqueueNDRangeKernel ( -4 )
    Trial 1... 0
    Trial 2... 0
    Trial 3... 0
    Trial 4... 0
    Trial 5... 0
    ⚡ 14:10:56|gpuminer0 Worker stopping 0.216534 s
    min/mean/max: 0/0/0 H/s
    inner mean: 0 H/s
    Phoning home to find world ranking...
    Error phoning home. ET is sad.
  • Michael_AMichael_A LondonMember Posts: 61
    make sure you have
    1) All your driver updated
    2) etherminer installed correctly step by step:
    cd cpp-ethereum
    cmake -DETHASHCL=1 -DGUI=0
    make -j4
    make install
  • Michael_AMichael_A LondonMember Posts: 61
    edited June 2015
    3) make sure you have the last version of ethereum: brew update && brew upgrade

    Personally I always use geth --rpc to mine ( I don't like the eth fonction ):

    geth --rpc then open an other terminal and ethminer -G -M --opencl-platform 1 --opencl-device 1 for the test or ethminer -G --opencl-platform 1 --opencl-device 1 for the actual mining
    Post edited by StephanTual on
Sign In or Register to comment.