RX560 gpus won't work after flashing

tstriketstrike Member Posts: 22
Hi there,

I'm currently building my 6th rig and since the shortage of RX 580 cards in the market i decided to build a low-range RX 560 rig with 9 cards for a change.

So it's build and operational, but then it was time to update the bioses with mining timings and that's where it goes south.

I copied each rom with atiflash, used polaris bios editor and applied the one step memory fix, updated the bios, reboot and then windows reports the RX 560 card is not working properly... And not only one card, but all cards i updated.

So because of the GPU shortages, i have 3 different RX 560 cards. 2x Sapphire Pulse, 3x Gigabyte OC and 4x MSI Aero ITX OC, all 4 GB ofcourse. They all have different bioses and i modded each card individually. All cards have the same problem. If i reflash their original ROM, they start working again, but not with a decent hashrate.

The OS is a clone from one of my other RX 580 rigs.
I tried Polaris 1.6.4 and the latest 1.6.7.
I tried AMD drivers 17.11 (Crimson), which i found out are working the best on my other rigs, and the latest 18.2.3, but both have the same problem.

Anybody got any clue why windows reports the GPUs not working correctly after i flash a modded bios? I'm quite lost with this one. Please help.


ps. don't buy the Gigabyte cards. I found out they only have 14 compute units, while the Sapphire and MSI both got 16.

Comments

  • pjaspenpjaspen Member Posts: 15
    try using the Pixel Clock patcher... Also I'd recommend Bios from Anorak

    https://www.monitortests.com/forum/Thread-AMD-ATI-Pixel-Clock-Patcher
  • Ericjh801Ericjh801 Utah, USAMember Posts: 371 ✭✭✭
    Exactly what pjaspen said, you need to run the pixel clock patcher and it should make windows recognize them again correctly with a modified bios. I just did this for an RX 480. I actually picked up a 480 and 2 560's today, so going to try the 560's later (75.00 each used). Should be interesting.
  • Ericjh801Ericjh801 Utah, USAMember Posts: 371 ✭✭✭
    I just setup 2 560's and they are getting almost 14 MHS each. Not too shabby.
  • cjclm7cjclm7 Member Posts: 77
    hardware reset a GPU is not that difficult (need a paper clip to short two pins in the back plate of the GPU)

    My friend had same issue with RX580. He followed the procedure (google hard reset bricked RX480 or RX560) and then he recovered 100% his unresponsive GPUs.
  • tstriketstrike Member Posts: 22
    edited February 2018
    Thanks pjaspen, that did indeed work. Where can i get that Anorak bios?


    I modded the bios now and the rig is running with no further tuning/tweaking, i still have to do that but first i need to have the rig really stable.

    However:
    After modding the Gigabyte cards, mining goes up only 0.1 or 0.2 MH/s (10.8 now).
    After modding the Sapphire cards, mining goes DOWN 0.3 MH/s (10.1 now). What the heck?
    After modding the MSI cards, mining goes up 1.2 MH/s (12.0 now).

    I now found out that both the Sapphire and Gigabyte cards only have 14 cores, while the MSI has 16. So those 2 extra cores the MSI card has, do have a big influence on the performace.

    Can anybode explain how these Sapphire cards have worse performance with a memory tweaked bios than with the stock bios?

    Please keep in mind that the miner is still running with all settings default, so with tuning these cards i might give them another +2 MH and lower power usage, but at least it's very clear that the MSI cards have far greater performance than the Sapphire/Gigabyte cards.
Sign In or Register to comment.