MSI Z170A Gaming Pro Carbon problem - black screen with gpu

Switcher89Switcher89 Member Posts: 2
Hey guys!
I've got a bit of a situation here... my rig started acting weird so i uninstalled the drivers. After that, windows wouldn't boot. But that is not the problem.
I've got a problem that when there is a GPU attached to an pcie slot via riser (haven't tried without) the system shows only black screen... no bios boot, no windows, nothing. When i remove the GPU from the pcie slot, windows boots normally from the internal graphics card.
I've updated the bios to the latest version 18? I've set the bios settings of PEG0, PEG1 to Gen1 and it makes no difference with the gpu plugged if i set 4g decoding to enabled or disabled.
Must i change anything else?

Desperate for help as i lost a lot of hours with trial and error but with no luck.

Thanks!

Comments

  • 20y74r120y74r1 Member Posts: 1
    I can solve your problems. I am mailing to you. [email protected]
  • SkirganaitorSkirganaitor Member Posts: 17
    I had his issue as well, but i had the Z170A PC Mate. How i fixed it was going into the bios and changing the integrated graphics to IDP or whatever the second option was, and plugging the hdmi right into the mother board.
  • Switcher89Switcher89 Member Posts: 2
    Well... did some testing. Attached the beeper to the MB. Signals GPU error :/ I think that the PCIE slots went off... dont know why though...
  • Switcher89Switcher89 Member Posts: 2

    I had his issue as well, but i had the Z170A PC Mate. How i fixed it was going into the bios and changing the integrated graphics to IDP or whatever the second option was, and plugging the hdmi right into the mother board.

    Well the system boots with the graphic installed if its set to IGP... but in Windows, under device manager it shows the GPU with an exclamation and CODE 43 error. Istalled new drivers and its the same. Like i said... i think the pcie ports are gone... i dont know why :(
  • glenn_txglenn_tx Member Posts: 67
    edited January 2018
    I forgot what the option is called, but the BIOS option that allows for more than 4 GPUs - turn that OFF, change PCIE to auto (and have 4 or less GPUs plugged in). Install AMD Radeon for 4 GPUs. Once that is fully successful, THEN turn on the option for more than 4 GPUs and change to 1X for PCIE. I learned that after hours of trial and error.
  • glenn_txglenn_tx Member Posts: 67
    Oh, and you may still get the black screen, waiting forever for something to happen. Occasionally, you have to unplug to 4 or less GPUs, turn the "more than 4" option off, change PCIE to auto. Get it to boot properly. Then you can change the settings back to allow for 7 GPUs, and it'll start working. It's a horrible bug that's been there from the first MSI MB that claimed compatibility for more than 4 GPUs, but they have yet to fix it fully. It's definately better than it used to be, but still can be a problem.
Sign In or Register to comment.