Nanopool email setting in Claymore (Linux OS)

chaffychaffy Member Posts: 36
Is this the correct format to add an email address to Claymore's start.bash file for nanopool?

-ewal WALLET_ADDRESS/MINER_NAME/[email protected]

I've updated the start.bash file with this info, started Claymore, but the current hashrate doesn't move and I can't login using the email address I put in there. Am I just not waiting long enough for the miner to run for these changes to show on nanopool?


  • Ericjh801Ericjh801 Utah, USAMember Posts: 371 ✭✭
    That looks like the correct format, it can take an hour or so for the hashrate to update and another few hours before it will accept the email address you entered to change it. (or a day, it's odd sometimes).
  • chaffychaffy Member Posts: 36
    Gotcha. I'll update it again and let it sit. It's just weird letting it run without seeing the balance update on my nanopool account page. I assumed it wasn't updating because it was taking the wallet/name/email as one whole wallet ID. Will claymore not launch if the wallet ID is an incorrect format?
  • XcoderXcoder Member Posts: 35
    Have you tried with a different MINER_NAME. Then you could immediately see when the first shares with the new information have arrived on your account. One the "new" miner is shown the login should work.
  • chaffychaffy Member Posts: 36
    Yep @Xcoder It's been siting with a new name since yesterday but I'm still showing the old name.
  • chaffychaffy Member Posts: 36
    I went to check my start.bash file and I have no idea how but the wallet listed was not the correct wallet. I did get up in the middle of the night a few nights ago and realized the rig had shutdown. What's really strange is even though a different wallet was listed, my nanopool page was updating with hashrates and balance increases. I shut the whole rig down for 20 minutes and watched nanopool report my miner was offline. The other wallet address didn't show any changes. I put my wallet back in and fired it back up, watched nanopool update with the hashrates and showing my miner online. Still no name change, I'm going to check it again first thing in the morning.

    I did a quick check on when the last time root was logged in and it never was. My other account doesn't show any random logins either. Weird as hell...
  • chaffychaffy Member Posts: 36
    Still showing the original name and I still can't get into the settings. I wonder if it might have to do with my email address containing periods in it. I'll swap my email address for another one tonight to test.
Sign In or Register to comment.