Mining on the Macbook Pro's AMD RAdeon 560 GPU

meltdownermeltdowner Member Posts: 12
edited December 2017 in Mining
I manage over 4000 macs. I'm looking for a way to turn the ones that aren't in use into something profitable. (Yes I have approval to test this so relax naysayers)

I've recently been trying to get ethminer to run on the latest 2017 MacBook Pro's since they have a GPU that should* be able to mine above 7Mh/s* @ 50watts.

Anyway, I've tried for about 7 hours yesterday to get it working and just could not get it going. For the record, running under dual boot windows or ubuntu (even under parallels is out of the question) - licensing.

Here's the error I get when running ethminer:

/ethminer -G -M --opencl-platform 0 --opencl-device 1 ℹ 12:34:20| Found suitable OpenCL device [ Intel(R) HD Graphics 630 ] with 1610612736 bytes of GPU memory Benchmarking on platform: CL Preparing DAG for block #0 cl 12:34:20|cl-0 No work. Pause for 3 s. Warming up... cl 12:34:23|cl-0 New work: header #50c856ae… target 0000000000000002000000000000000000000000000000000000000000000000 cl 12:34:23|cl-0 New seed #00000000… cl 12:34:24|cl-0 Platform: Apple cl 12:34:24|cl-0 Device: AMD Radeon Pro 560 Compute Engine / OpenCL 1.2 cl 12:34:24|cl-0 Build info: cl 12:34:24|cl-0 Creating light cache buffer, size 16776896 cl 12:34:24|cl-0 Creating DAG buffer, size 1073739904 cl 12:34:24|cl-0 Loading kernels cl 12:34:24|cl-0 Writing light cache buffer cl 12:34:24|cl-0 Creating buffer for header. cl 12:34:24|cl-0 Creating mining buffer cl 12:34:24|cl-0 Generating DAG cl 12:34:24|cl-0 DAG 0 % cl 12:34:25|cl-0 DAG 6 % cl 12:34:25|cl-0 DAG 12 % cl 12:34:26|cl-0 DAG 18 % cl 12:34:26|cl-0 DAG 25 % cl 12:34:26|cl-0 DAG 31 % cl 12:34:27|cl-0 DAG 37 % cl 12:34:27|cl-0 DAG 43 % cl 12:34:28|cl-0 DAG 50 % cl 12:34:28|cl-0 DAG 56 % cl 12:34:29|cl-0 DAG 62 % cl 12:34:29|cl-0 DAG 68 % cl 12:34:29|cl-0 DAG 75 % cl 12:34:30|cl-0 DAG 81 % cl 12:34:30|cl-0 DAG 87 % cl 12:34:31|cl-0 DAG 93 % cl 12:34:31|cl-0 Switch time 10273 ms / 7268211 us Trial 1... 7869238 Trial 2... 8082117 Trial 3... 8078074 Trial 4... 8181347 Trial 5... 8182165 ✘ 12:34:50|cl-0 OpenCL Error: clSetKernelArg -48 min/mean/max: 7869238/8078588/8182165 H/s inner mean: 8113846 H/s

I followed a guys guide I found here...

In a nutshell his instructions are this:
  1. Install Xcode (app store)
  2. Install cMake (used for building binary on osx)
  3. -/usr/bin/ruby -e "$(curl -fsSL"
  4. -brew install cmake
  5. Install ethminer
  6. -git clone
  7. -cd ethminer; mkdir build; cd build
  8. -cmake ..
  9. -cmake --build .
That builds the ethminer binary on osx however I constantly get the following error when attempting to mine: OpenCL Error: clSetKernelArg -48

Driving me nuts. Tried multiple systems. I feel like this is an opencl issue but where? In the code or on the system?

I've also tried just about every variation of ethminer. Tried ethminer version 10-12. All same error. OpenCL comes with OSX 10.12.6 (the version im running) so I'm not sure what else I'm missing here..
Post edited by meltdowner on


Sign In or Register to comment.