Terminating discover after 0 rounds

Shadow358Shadow358 Member Posts: 10
Hey guys,

I am pretty new to Ethereum and first of all I tried to connect to the network with AlethZero but I constantly get this error:

*** [ 11:22:05 | p2p ] UPnP device not found.
*P* [ 11:22:05 | p2p ] refreshing buckets
*N* [ 11:22:05 | p2p ] p2p.started id: 7a099288έΑο
*P* [ 11:22:32 | p2p ] Terminating discover after 0 rounds.

after pressing the Go! button . I ran AlethZero both on Linux and Windows but I get the same every time.


Edit: I randomly didn't get that error just once but I got this:

-W- [ 11:07:33 | eth ] BQ ==> CHAIN ==> STATE
-W- [ 11:07:33 | eth ] preSTATE W> [ 11:07:33 | eth ] WORK
-W- [ 11:07:34 | eth ] BQ ==> CHAIN ==> STATE

Which basically means that I'm still not connected to the network


Post edited by Shadow358 on

Comments

  • GenoilGenoil 0xeb9310b185455f863f526dab3d245809f6854b4dMember Posts: 769 ✭✭✭
    Hi,

    I get the same thing in console version (built Win32 from today's source). Tried all possible command-line parameters that I thought could make a difference. Enabled port forwarding and even DMZ on my router...nothing but this message. Also in pre-built Win32 binary of Alethzero btw.
  • roz303roz303 Member Posts: 66
    I got it for Ubuntu up and running today, getting the same thing. Now, since it has "P2P" errors, it might be safe to assume it's a network problem. Forwarding? I don't know. Hope we can find a solution!
  • mtbxmtbx Member Posts: 16
    edited March 2015
    I am taking a guess that the main node(poc-8.ethdev.com:30303) that we are connecting to is going down and up at random times causing these issues.

    It would be nice to have something continuously up so that testing can occur
  • Shadow358Shadow358 Member Posts: 10
    Is it even possible to connect to a different node than the main one(poc-8.ethdev.com:30303) ? If yes is there a tutorial how to do that because the "connect to peer" option in AlethZero is not working for me.
  • mtbxmtbx Member Posts: 16
    I could never get it to connect to a different node even with the ports open on both ends
  • Shadow358Shadow358 Member Posts: 10
    but you were able to connect it to the main node ?
  • roz303roz303 Member Posts: 66
    edited March 2015
    I tried

    ./eth -r poc-8.ethdev.com -p 30303

    and

    ./eth -m off -o peer -u 65.78.90.42 -x 256

    and am getting the same thing.
  • Shadow358Shadow358 Member Posts: 10
    I have tried those as well as everything else I could find on the forum and still didn't work. I've was never able to connect to the main node and yesterday I was experimenting with connecting to other nodes on the same (local) network. When I typed
    ./eth (and the IP of the node who had started the server)

    the output was this was a successful connection to that node, but since it was from the CLI I couldnt test any contracts I had. I tried the same thing with AlethZero:
    ./alethzero (and the IP of the node who had started the server)

    but this did not work... also the connect to peer button is not working for me.
  • sumosumo Member Posts: 3
    I keep getting this error too. Anyone know how to fix it?
  • Shadow358Shadow358 Member Posts: 10
    The Ethereum chain is pretty unstable at the moment so consider creating and working/experimenting on a private chain with a couple of lads of yours. It also could be that the ports used by Ethereum are blocked. And its not really an error, you still get it after you are connected.
  • mementomemento Member Posts: 1
    I have the same problem.
    I just followed these instructions for ubuntu 14.04 :
    ---
    Installing cpp-ethereum on Ubuntu 14.04, 64 bit
    For the latest stable version:

    sudo add-apt-repository ppa:ethereum/ethereum-qt
    sudo add-apt-repository ppa:ethereum/ethereum
    sudo apt-get update
    sudo apt-get install cpp-ethereum
    ---

    Does anyone have a clue ?
  • hanzzs208hanzzs208 Member Posts: 6
    memento said:

    I have the same problem.
    I just followed these instructions for ubuntu 14.04 :
    ---
    Installing cpp-ethereum on Ubuntu 14.04, 64 bit
    For the latest stable version:

    sudo add-apt-repository ppa:ethereum/ethereum-qt
    sudo add-apt-repository ppa:ethereum/ethereum
    sudo apt-get update
    sudo apt-get install cpp-ethereum
    ---

    Does anyone have a clue ?

    Same problem here.

Sign In or Register to comment.