Benchmark and overclock on Linux GTX 1060

BrunoCzarBrunoCzar Member Posts: 30
Hi,

First of all, sorry if I am creating a repetitive post, but I didn't found nothing so specific on search.

I would like to share my first benchmark and at the same ask about specific overclock. After a small war, I finally put my RIG to work.

Specifications:
Mob: ASUS PRIME Z270-P
Processor: Celeron g3900
RAM: 4GB DDR4 2133MHz Kingston ValueRAM
PSU: 2x Corsair CX750
GPU: 8x NVIDIA EVGA GEFORCE GTX 1060 6GB SSC ACX 3.0.

Software:
OS: Linux Server 14
Dev: CUDA 8
Driver: NVIDIA-Linux-x86_64-384.59
Miner: Claymore v9.7
Pool: Nanopool

In this configuration without any overclock, I got 158,8mh/s, about 19,85mh/s per card. Well, I had to mix many tutorials in order to put everything working. Mainly I followed youtube video "How To Build an 8 GPU Mining Rig BlackOctane" and this post for software https://forum.ethereum.org/discussion/7780/gtx1070-linux-installation-and-mining-clue-goodbye-amd-welcome-nvidia-for-miners.
Some extra actions were required on the BIOS and some adjustments on Linux to work with 8 gpu, I intend to produce a tutorial when I'm done.

The thing now is that I got my mind exhausted to run after a nice overclock setting. As the guy above is using 1070 I got worried to overload my 1060s. This post seemed more suitable but his GPUs are smaller: https://forum.ethereum.org/discussion/11934/undervolt-a-gtx-1060. I was thinking if I can take much more from 6gb SSC model.

Can someone please share one complete script with suggested parameters? I really need to fake 8 monitors? There is no simpler way?


Comments

  • BrunoCzarBrunoCzar Member Posts: 30
    Well,

    I made it with xinit, nvidia-smi and nvidia-settings. Now I have 185mh/s, about 23,12mh/s per card: energy at 80w +120clock +1200men fan 60%.

    Someone suggest to increase something?

    Also, I set the machine to turn itself on as soon as the power returns, on powerfailure. Set auto login and call the start.sh just after it.

    My problem now is configure both things together. When I execute xinit the machine screen go white. Then I used a notebook to execute overclock.sh and start.sh. I won't be able to do that on powerfailures.

    How can I call others scripts after xinit?

  • rmhrmh Member Posts: 410 ✭✭✭
    My problem was with nvidia, that i don't want to login to X and/or playing with dummy monitor configs, just use ssh and control everything from command line.
    Solution for using nvidia-settings without properly configured Xauthority:

    GPU=0
    MEM=1000
    CLO=100
    sudo DISPLAY=:0 XAUTHORITY=/var/run/lightdm/root/:0 nvidia-settings -t -a "[gpu:${GPU}]/GPUMemoryTransferRateOffset[3]=${MEM}"
    sudo DISPLAY=:0 XAUTHORITY=/var/run/lightdm/root/:0 nvidia-settings -t -a "[gpu:${GPU}]/GPUGraphicsClockOffset[3]=${CLO}"
  • KlintistwoodKlintistwood Member Posts: 142
    @BrunoCzar You can solve the multi/fake monitor issue by adapting the content of you xorg.conf file. For the tweaking, I recently posted my settings but can't find the thread anymore. I'm above 24MH/s with my GTX 1060 on Ubuntu so you can probably push a little bit more.
  • BrunoCzarBrunoCzar Member Posts: 30
    With 80w +40clock +1500men fan 60% it passes the 24mh/s

    I'm still taking a beating from xinit. I set the commands on .bash-login the my home dir.

    1. I'm in the console environment tty1.
    2. When run "xinit" it open a rough screen on tty7.
    3. By pressing CRTL+ALT+F1 I go back to terminal tty1 but is stucked on the "xinit" command. That is why, the .bash-login script don't execute any other command after.
    4. By pressing CTRL+C it stops the tty7 environment and the overclocked don't work.
    5. Now the most strange part: If I press CTRL+Z, I return the control, the overclock works, but when I run the program, only GPU0 start to work.
    6. Also tried "setsid xinit &> /dev/null" and again, everything seens perfect, but only GPU0 work.
    7. Another approach: in the rough screen, tty7, I click with the mouse on the upper command line, type overclock.sh and it works. All 8 gpus work nicely. This seems to be more closely to what I want.

    The problem is that in a power failure event, it will go back to run without overclock. There is a way to define commands to execute as soon as the tty7 environment is up?
  • KlintistwoodKlintistwood Member Posts: 142
    Add everything in a .sh file and make it run at boot before starting your miner, that should work.
  • BrunoCzarBrunoCzar Member Posts: 30

    Add everything in a .sh file and make it run at boot before starting your miner, that should work.

    I tried this content on .bash_login:
    xinit;
    /home/user/overclock.sh;
    /home/user/start_nanopool.bash;

    It didn't work. After boot, the screen was on tty7 and tty1 was stucked in the xinit command.

    Then I hit CTRL+C then it executed overclock.sh and start_nanopool.sh.
  • rmhrmh Member Posts: 410 ✭✭✭
    ~/.xinitrc will run after x started
  • BrunoCzarBrunoCzar Member Posts: 30
    Finally, I did it!

    I have tried already the xinitrc file from /etc/X11, it wasn't working. I searched the default command for xinit, it only make a call for xterm.

    Then I searched xterm and I found the parameter -e "command".

    So basically I create:
    .bash_login with "xinit"
    .xinitrc with "xterm -e "start_mining.sh"

    Put the overclock commands inside start_mining.sh

    It is working, restarted more than once: it opens the tty7 interface, make the overclock and start mining.

    The RIG is making 190mh/s and using 750w (measured with external tool).
Sign In or Register to comment.