RX 480 - 990FXA / Z97 - Rig freezes - Driver crash

agahnimagahnim Member Posts: 7
Hello all,

I searched for days and tried everything that seemed like a solution, but I'm slowly giving up hope of getting my rig to work. I have mined perfectly in 2015 with 280x cards, but for some reason I can not get rx 480 cards to behave.

I can mine without issues when inserting only 1 GPU either directly onto the MB or with a powered riser. Only when inserting 2 or more GPU's with risers, added card(s) drops to 0MH/s within seconds, but only for the GPU(s) that are not in the "main" PCI-e slot. The "main" GPU never causes the crash. After halting to 0MH/s my rig freezes. When I notice my hashing going down to 0MH/s on a card and I can still quickly close the miner, my catalyst driver crashes.

At the time of freezing, GPU-z reads 0% on memory controller load on the crashed card(s).

My setup:
Gigabyte 990FXA-UD5 (newest firmware)
Amd sempron 145
Corsair RM1000
4x Asus RX 480 Dual OC 8GB
2x4 GB Ram
SSD 60gb
Windows 10 64bit pro
Virtual memory set to 16gb
Powered risers rev006
Current driver: 16.9.1
Mining ETH with Claymore 9.4
GPU temps are 65°C

I have also tested on a Asrock Z97 Extreme 4 motherboard (newest firmware), tried different risers (even old ribbon risers), all with similar results.
I have tried setting PCI-e gen to auto/1/2/3 on the Z97 mobo, the 990FXA doesn't even have this option.
I tried different miners (qtminer)

Is there anyone that can help me with some advice?


  • john1john1 Member Posts: 9
    Hello agahnim
    i have a similar problem but using ethos ,did you manage to get this sorted out ?
  • agahnimagahnim Member Posts: 7
    No, not yet. Still busy trying everything I find.
    Even downclocking (memory including) does not work.

    I am going to do a full reinstall of windows 10 now. If it does any good, I will update my post.
  • jsanzspjsanzsp Member Posts: 195 ✭✭
    edited June 2017
    try claymore 8.1, 16.9.2 drivers or 9.4 whit option -asm 0
  • JukeboxJukebox Member Posts: 640 ✭✭✭
    Maybe Crossfire mode set to "enabled"?
    Check with GPU-Z
  • agahnimagahnim Member Posts: 7
    edited June 2017
    jsanzsp said:

    try claymore 8.1, 16.9.2 drivers or 9.4 whit option -asm 0

    Trying this (claymore 8.1 and 16.9.2 drivers) quickly before reinstalling w10 or trying EthOS. Testing with only 2 cards inserted (both with risers), 30 minutes of happy mining so far.

    I'm also monitoring for GPU memory errors now, 0 errors on both cards (not sure if I had any previously, probably not).
    Jukebox said:

    Maybe Crossfire mode set to "enabled"?
    Check with GPU-Z

    Is disabled via radeon settings


    Also, my GPU load and Memory controller load always keep jumping from 100% to brief 0% lows. I'm on original bios. Something to worry about, or is it common?
Sign In or Register to comment.