Troubles having my 6th rx 470 4gb MSI workin on H81 PRO BTC 2.0

rocksodrrocksodr Member Posts: 15
Hello, I am stuggling since 2 weeks to make my 6th card work.
They are MSI 470 gaming X 4GB Samsung memory card, all of them same batch.
Im on Windows 10 64bit pro.
USB powered risers straight from PSU
I swapped cards and risers and they work and mine correctly independently.
When I book the detection of my 6th card is random, sometimes its detected sometimes not, and when It is I get BSOD or only 5 card are mining and 6th one is idling at 0MH/S...
Here is what I tired :smile::smile:
- Clear CMOS
- Set PCIE to gen 1 (in GPU Z one GPU displays PCIE x16 3.0 @ x1 1.0 and all other 2.0 when I have 5 card detected on 6... and when I have 6 cards detected all slots are at 1.1 and only one at 2.0, can this be the issue ?
- My power supply is 1200W gold rated zalman 1200 EBT
- My ram is random 8gb stick
- 6 GPU PATCH
- Should I try pixel clock patch ? I didnt try
- Reinstall Windows
- Tried mining with simplemining.net linux software : only picks up 5 cards too
- Claymore miner different versions
- Drivers 16.9.2 (currently mining with 5 card on that with success) / 16.11.5 / 17.4.3
- Plugging MOLEX to the motherboard 4pin slots
- Drinking a lot of cofee
- Watching eth pump

Im quite desperate about that last card, and I guess it will end up in my gaming PC and mining from it if I dont find a solution :(
Here's a pic of my rig. Im kinda sad it doesn't work as intended, I even painted the frame black myself :open_mouth:
image



Comments

  • pajchepajche Member Posts: 40
    If u are dual mining that psu maybe could not provide enough power?
    1. Check slot on MB, try all slots with one card.
    2. Uninstall drivers with ddu in safemode then install again 16.9.2
    3. DO NOT POWER MB WITH MOLEX IF U ARE USING USB POWERED RISERS
    4. Plug monitor to card connected in big slot (u should use some dummies or hdmi2vga connectors just to hang there, and you can connect with TW to rig. Avoid using integrated gpu for monitor. Maybe that can be a problem....

    Try those i wrote above, no.4 may be your solution....
  • JawboneJawbone Member Posts: 44
    I have to disagree with number 3. Using the molex in your mobo and powered risers isn't bad, just doesn't give you any benefit. It will only draw what it needs. It won't hurt it.

    OP, I would test that 6th card to ensure it works, but otherwise I'm stumped too. It should see it no problem. Disable on board LAN and other things that use pci lanes?

    Also no need for 6 gpu patch. That was for win7. Win10 sees up to .....8? I think.
  • yodiyodi Member Posts: 265 ✭✭
    edited May 2017
    i got problem with this mobo to ... i thought about default
    i never get it work with more of 5 gpu , tried everything , molex on mobo is useless with powered riser ,
    i lose some time , then i return the mobo ... and get msi z97 gaming 5 ... i try never get again new asrock mobo ...
    my old asrosk h81 btc (classic) work nice with 6 x gpu

    did you try a different riser from the bad gpu ?
    flash cards one by one , low the coreclock lot of time result bsod ...

    where do you from ?
    mays be you can try pci-e extender if have one :)
  • rocksodrrocksodr Member Posts: 15
    Hello, thanks for the replies.
    I have tried the cards independently and risers too and it works. It's clearly a driver / power issue to me because when I put in MSI afterburner a limit in power consumption and it mines at 10% the power the claymore (non dual) miner doesn't crash but I have the one card hashing 0 MH/S issue still... I have a dummy plug, I'll try putting it on the card on x16 slot I'll keep you up to date I'll retry everything as you said.
  • rocksodrrocksodr Member Posts: 15
    update : I reinstalled drivers and updated motherboard intel INF drivers (i have not tryed installing intel VGA for onboard screen yet)
    and I am mining with 6 gpu now... but at half the speed ! 400W at the wall lol
    this is driving me crazy

  • rocksodrrocksodr Member Posts: 15
    So its mining at half the speed cause afterburner set the clocks to 900 mhz...
    When I put them back to normal it mined all six GPU at 3=24MH/S
    then two minute later one CPU fell to 0MH/S
    and then BSOD restart...

    geez
  • rocksodrrocksodr Member Posts: 15
    So now it is even worst guys, even with 5 cards after 10-15 min of mining I have the error :
    GPU 4 hang in OPEN CL and I must reboot.
    atimkdtk error in sys log

    obviously theres some deep driver fuck up in my setup

    any chance of it working if I try on windows 7 or 8 ?
  • rocksodrrocksodr Member Posts: 15
    I want to try another motherboard, can anyone recommend one easy to find and not too expensive that works with a 1200W gold PSU and rx 470 cards ? thanks
  • densetsdensets Member Posts: 69
    what disk size are you using? set the paging to 24gb. or 32gb.
  • rocksodrrocksodr Member Posts: 15
    My paging is set to 20gb min 60gb max.
  • molletmollet Member Posts: 8
    The solution is very simple, plug in the HDMI of the Monitor to the GPU which is on the x16 slot.
    Clear Cmos and youre good to go.
  • thepixelgeekthepixelgeek PhillyMember Posts: 96
    edited May 2017
    I have that motherboard and 6 rx470's. All working just fine now. However, It has been a chore trying to get it all to work due to noob mistakes. That said, here's what I did:

    1. Fresh reinstall windows 10
    2. Hook up only one card in the x16 slot with monitor connected
    3. After new install of Windows, update windows using the "system update" screen. ! Make sure EVERYTHING is updated! It will include the AMD drivers.
    4. Restart and do another update to be sure it's all updated
    5. Check "Device Manager" to make sure your card is under "displays"
    6. Restart into bios, select gen 1
    7. Shutdown
    8. Hook up all six cards using powered risers
    9. Restart and open "Device Manager" again. ! Don't do anything else but watch the system find and add the other 5 cards...Windows will do this all on it's own. And dont' worry, it may flicker and glitch while processing ! Make sure it finds all 6 cards before closing...give it time, it may take a bit.
    10. Restart the computer only after you see all 6 cards without exclamation points
    11. Open your miner and start mining

    Don't forget to adjust virtual memory to 16000-20000.
    Post edited by thepixelgeek on
  • rocksodrrocksodr Member Posts: 15
    Hello, thanks for the answer.
    An update : my rig has been mining fine no crash for 15 minutes now (solo mining eth).
    What I did was plug the hdmi dummy plug in the card to the 16x slot as advised.
    I used driver cleaner as admin in failsafe mode to remove all drivers.
    Plugged all 6 cards at the same time.
    Installed drivers on the MSI rx 470 gaming X drivers 16.9.1 win10-64bit-radeon-software-crimson-relive-16.12.1-dec7.
    And it is mining fine since then...
    I also changed a PCIE power cable from the 6th card (I used the same cable coming from the 5th card) so now my 6 and 5 th card are on the same PCIE power cable. Anyone know if this is safe long term ? I have seen video of people doing that with no problem but I am not sure if its good, or if its what fixed my issue.
  • Jo3LJo3L Member Posts: 34
    @thepixelgeek @rocksodr how did u manage to put usb gen 1? i dont see the option in the mb...
  • thepixelgeekthepixelgeek PhillyMember Posts: 96
    Jo3L said:

    how did u manage to put usb gen 1? i dont see the option in the mb...

    Not USB...Gen 1 is referring to PCIe slots.

    -Enter motherboard bios settings
    -find cpu configuration (if memory serves me well)...think it's under overclock menu item...second menu item from the left.
Sign In or Register to comment.