No way: MOBO won't recognize any GPU

albertojamesalbertojames Member Posts: 13

MOBO MSI Z170A Carbon

The GPU is powered with the VGA cable AND SATA to the PSU. Riser to the PCI. But nothing happens, tried with different cards, raisers, PCI slots, VGA power cable, nothing happens.

Just both fans of the GPU keep running but the MOBO and the W10 won't see any connected GPU.

What could happen?


  • narba88narba88 Member Posts: 85
    what if you take it off the riser?

    Try another riser? Sometimes just reconnecting everything makes it works. Are you sure you didn't put the card in the riser upside down? :D

    What motherboard? Give us a rig breakdown...
  • albertojamesalbertojames Member Posts: 13
    Well :(

    It works if i set the GPU direct in the PCI slot without riser.

    But i tried with 8 risers and no one works - is that possible?
    What i'm missing?

    The 4-pin power connector in the Raiser is connected to the PSU.
  • albertojamesalbertojames Member Posts: 13
    Here is my RIG:

    MOBO: Z170A Carbon
    GPU: 6x MSI Armor RX 480 OC 4GB
    PSU: 1600w EVGA
    RAM: 4GB DDR4
    CPU: G4400 LGA1151
    Risers: 16x to 1x
    OS: Win10

    I'm trying with just 1 GPU:

    No GPU is in device manager when i use a riser. I've tried plugging in the 7 PCI Slots.
    No video when plugged with riser.

    What it's missing? :(
  • leelaam13leelaam13 Member Posts: 18
    Do you set PCI Gen x1 in BIOS?
  • yodiyodi Member Posts: 265 ✭✭
    win10 is up to date ? did install was done with internet connection ?

    check pci-e set to gen1 in bios.

    just put one card in pci-e directly then
Sign In or Register to comment.