4x Powercolor RX480 Red Devil PCIe Risers - Ethereum Mining.

gorgamingorgamin Member Posts: 18
edited September 2016 in IoT & Hardware
I'm having issues with my Powercolor RX480 Red Devil GPUs. I can't seem to get more than 2x cards running per system. I have identical systems with Reference RX480s and they run fine with 4x GPUs.

What I've tested so far:

All GPUs work fine on their own plugged directly into the motherboard.
All slots on motherboard work fine with PCIe risers using the Reference RX480s.

Motherboard has 4x PCIe slots (2x full length 16X and 2x short 1X). All 4x work fine on the reference RX480s

I can get 1x Red Devil RX480 card to work in any slot with a USB riser cable. If I plug in two cards it either won't start (the PSU relay just clicks but doesn't turn on. Tried another PSU, does the same) Or if I get it to boot, it won't load the driver for the second card and just detects it as a "Microsoft Basic Display Adapter". On one system I managed to get two to work, but it seems very unstable.

I've split up the 8pin power connectors so each card gets its own power rail on the PSU. It should be more than enough as the PSU supplies 40A per rail x4.
What worries me is that the powered PCIe usb risers are all connected on Rail 1 via the 4pin Molex connectors. But this should still be fine as the majority of the PCIe power drawn happens on the 12V pin, and the 5V that the powered risers convert to 3.3V should not use more than 7W per card ( on the Reference RX480 ) as shown here:

So I should be safe on the 5V. The AIC1084 chip that does the voltage regulation from 5V to 3.3V is rated to 5A.


This leads me to suspect either my powered pcie usb riser cables, the motherboard or the PSU rails (Rail 1 might be overloaded from the powered risers).

I've also gone through the PCIe usb risers, testing everything for shorts or that the pins are connected where they're supposed to be. The risers work fine with the reference RX480s.

MSI Mortar B150
4GB of RAM (tested)
Windows 10 64bit
Antec High Current Pro HCP-1000 Platinum 1000W 80PLUS Platinum.

+3.3V +5V +12V1 +12V2 +12V3 +12V4 -12V +5Vsb

MAX 25A 25A 40A 40A 40A 40A 0.5A 3A
Total ===130W=== ---------- 1000W-------------- 6W 15W

Please help... tearing my hair out in this process of elimination.


  • gorgamingorgamin Member Posts: 18
    edited September 2016
    My gut feeling still tells me its the risers. Its the only non-standard component. Perhaps they're not compatible with the Red Devil RX480? However I've tried tested and working (on the Reference RX480) risers on the cards.
  • king_pinking_pin Member Posts: 2
    I have no problems running 6 of those with USB and/or standard extenders!
    I have problems making them go beyond 25MH/s but that is another story LoL
  • gorgamingorgamin Member Posts: 18
    edited September 2016
    king_pin said:

    I have no problems running 6 of those with USB and/or standard extenders!
    I have problems making them go beyond 25MH/s but that is another story LoL

    Push your memory up to 2250MHz, power limit by 14%, lower your GPU MHz to 1266Mhz. Up your fan to 75%. Should reach 27MH/s easily on Windows 10. I've noticed however that this works best with Ethereum mining only. The power draw of dual mining adds more instability.

    And use ASUS GPU Tweak or Sapphire Trixx 3.0 (it works on any RX480/RX470.) Save a profile and set it to load the profile on startup automatically.
  • gorgamingorgamin Member Posts: 18
    Found the issue. Was a faulty GPU. Sent it back for RMA.
  • gorgamingorgamin Member Posts: 18
    Some of the risers were faulty too. I believe they were the problem from the start. Always suspect the risers first.
  • guntisvitolinsguntisvitolins Member Posts: 24
    6x RX480 setup Red Devils at 188mh/s
Sign In or Register to comment.