Building go-ethereum on Ubuntu 14.04: no GUI build

AronVanAmmersAronVanAmmers ✭✭Amsterdam, NetherlandsMember Posts: 40 ✭✭
Hi,

In order to stay current with the bleeding edge of development (and hopefully be able to use some functionality that is broken/missing in the current release build), I'm trying to build go-ethereum on an up-to-date Ubuntu 14.04 system.

Building and running the CLI version works. Building the GUI however, does not.

I followed the instructions using the automated installation script. Output of (re-)running the script:
$ ./install 
Installing Go and QT5 from PPA
This may prompt for your password.
Package: qtbase5-private-dev
Status: install ok installed
Priority: optional
Section: libdevel
Installed-Size: 5181
Maintainer: Ubuntu Developers
Architecture: i386
Multi-Arch: same
Source: qtbase-opensource-src
Version: 5.2.1+dfsg-1ubuntu14.2
Replaces: qtbase5-dev (<< 5.0.2+dfsg1-3~)
Depends: qtbase5-dev (= 5.2.1+dfsg-1ubuntu14.2)
Pre-Depends: dpkg (>= 1.15.6~)
Breaks: qtbase5-dev (<< 5.0.2+dfsg1-3~)
Description: Qt 5 base private development files
Qt is a cross-platform C++ application framework. Qt's primary feature
is its rich set of widgets that provide standard GUI functionality.
.
This package contains the private header development files for building some
Qt 5 applications like Qt Creator QML Designer plugin.
.
Use at your own risk.
Homepage: http://qt-project.org/
Original-Maintainer: Debian Qt/KDE Maintainers <[email protected]>

Exporting environment variables.
Dependencies satisfied.

Now installing the ethereum client
# github.com/go-qml/qml
../go/src/github.com/go-qml/qml/error.go:4: "ERROR: the correct import path is gopkg.in/qml.v1 ... " evaluated but not used

Installation complete
Before continuing please source ~/.bashrc or open a new terminal.

You can now start Ethereal by issuing:

cd $GOPATH/src/github.com/ethereum/go-ethereum/ethereal && ethereal

If you rather run without a GUI you can start ethereum by issuing the 'ethereum'
command. More informations on:

https://github.com/ethereum/go-ethereum/wiki
The line with ERROR: the correct import path is gopkg.in/qml.v1 ... seems suspicious.

The result of this is that ~/go/bin/ethereum exists, but ~/go/bin/ethereal does not.

When I try to manually get/build ethereal, I get this output:
$ go get -u -a github.com/ethereum/go-ethereum/ethereal
go install runtime: open /usr/lib/go/pkg/linux_386/runtime.a: permission denied
To avoid this "permission denied" error I repeated the whole process as user root. The output of the install script is the same. The manual install outputs:
# go get -u -a github.com/ethereum/go-ethereum/ethereal
# github.com/go-qml/qml
go/src/github.com/go-qml/qml/error.go:4: "ERROR: the correct import path is gopkg.in/qml.v1 ... " evaluated but not used
Which is the same error message as the original install script showed.

The instructions mention that Ubuntu 14.04 has Qt 5.2.1 by default, and 5.2.0 is necessary. I installed Qt 5.2.0 just to be sure, which doesn't change the result.

Any help is appreciated.

Cheers,
Aron

Comments

Sign In or Register to comment.