Setting LSLOC in Cmakefile

Hi all, I'm getting an error:
CMake Error: The following variables are used in this project, but they are set to NOTFOUND.
Please set them or make sure they are set and tested correctly in the CMake files:
LSLOC

What is this variable and what does it need to be set to?

-- redmage

Comments

  • nejucomonejucomo Member Posts: 40
    I get the same error, and I'm not sure how to fulfill the missing information. I'm unfamiliar with cmake. If I figure it out, I will let you know, but in the meantime there's at least two of us with this problem.
  • nejucomonejucomo Member Posts: 40
    Ah, look at the output above the error and you should see some message about a dependency not meeting the criteria for cpp-ethereum. In my case I have:

    ```
    -- Found Crypto++: /usr/include/cryptopp, /usr/local/lib/libcryptopp.so
    -- System Crypto++ version found is smaller than 5.6.2.
    -- System Crypto++ not found, broken or too old. We use LSLOC-NOTFOUND
    ```
  • nejucomonejucomo Member Posts: 40
    Beware: Once I installed Crypto++ 5.6.2, I still got the same error until I removed the ./build directory and created it from scratch, so the dependency checking has error prone caching.
Sign In or Register to comment.