[ERROR]: OpenCL 1.0 is not supported.

TrantidonTrantidon Member Posts: 65
Hello, I am trying to mine from a machine with ubuntu server 14.04 and a old graphics card: NVIDIA GEFORCE 330 2GB. I am running into some error which I cannot find any documentation that helps me so I would appreciate some help, thanks.

clEnqueueWriteBuffer(-36)
OpenCL 1.0 is not supported.

I guess this has something to do with the drivers of the card, maybe it is impossible to mine with this card, I dont know. I have installed the drivers directly from NVIDIA's site I suppose currecly, the card shows under ethminer --list-devices.

Any support would be appreciated.

Comments

  • dlehenkydlehenky ✭✭✭✭ Member Posts: 2,249 ✭✭✭✭
    It means that GPU only supports version 1.0 of OpneCL , which is lower than that necessary to run the miner (kernel), i.e. that card won't run OpenCL.
  • TrantidonTrantidon Member Posts: 65
    dlehenky said:

    It means that GPU only supports version 1.0 of OpneCL , which is lower than that necessary to run the miner (kernel), i.e. that card won't run OpenCL.

    Thanks for the answer.

    I tought it was something lime that yes, but what Im more curious is this can be circunveid un some way (cuda?) . does this mean there is no way to mine with my card? Thx
  • dlehenkydlehenky ✭✭✭✭ Member Posts: 2,249 ✭✭✭✭
    Try the "CUDA mining" thread and ask. I *think* the answer is no, your GPU is too old, but I am no expert on Nvidia. @Genoil has a version of ethminer specifically for Nvidia/CUDA GPUs which is the subject of the thread I mentioned above.
Sign In or Register to comment.