Computer freezes after a while - multi GPU mining AMD + NVidia

OrangeBubblegumOrangeBubblegum Member Posts: 52
So Ive got a multi GPU setup, running on Asus P8Z68-V PRO + 2500k. Currently its got two AMD 380s and a 980ti. One of the 380 is on the top PCI-e slot and another one is on the last PCI-e slot using a USB riser. The 980ti is on the second PCI-e slot.

The first 380 and 980ti work perfectly using genoils, on two seperate instances of ethminer, but the moment Ive put in the second 380 using a USB riser my PC freezes a lot. Im currently testing the 380s without the 980ti mining over the next few hours to see if I can mine without anything crashing.

Ill also try various opencl local and global settings. Is it possible that the opencl local and global settings are causing my computer to freeze?

Do you think it could be my PCI-e slots? Should I try forcing all the cards into PCI-e 1x to see if that might help?

Appreciate any help.

Cheers.

Comments

  • Benni93Benni93 Member Posts: 50
    Just to understand, the PC freezes if u start mining on 3rd Card or if you hot plug the card into the system?:O
  • ma68546ma68546 Member Posts: 9
    I think it could be DAG-File related.
    what version of Genoil do you use?
    try using the latest 1.1.7 version that generates the DAG File on the GPUs itself.
    I had some similar issues because the ethminers wanted to access the same DAG file and somehow could not do so.

    Once I fixed some recent freezing error by removing my 20year old hdd with a new ssd ;) :)
  • GenoilGenoil ✭✭✭ 0xeb9310b185455f863f526dab3d245809f6854b4dMember Posts: 769 ✭✭✭
    my 1.1.7 also support mixed mode (Nvidia + AMD on a single instance) mining. Use -X instead of -G/-U. Could be that it doesn't work with getWork yet, only Stratum.
  • OrangeBubblegumOrangeBubblegum Member Posts: 52
    @Benni98 : No, it freezes when all three are plugged in before boot.

    @ma68546 + @Genoil : Im currently using 1.0.8, I wasnt aware that 1.1.7 was out. Think I might be a bit behind on that. Where can I grab 1.1.7 from? Ill try using -X once Ive got it. I was using two instances before, with separate DAG locations.

    Im using an SSD but I have another system Im trying to get up and running with HDD and its got the same issue but Im using 1.0.8. Ill try 1.1.7 once I get my hands on it.

  • OrangeBubblegumOrangeBubblegum Member Posts: 52
    edited June 2016
    Ive managed to get 1.1.17 and have got it working on my system with a NVidia and AMD GPU. Ive got it running in stratum mode. Why do I need to put in a password eg. -O address.workername:password
    Post edited by OrangeBubblegum on
  • GenoilGenoil ✭✭✭ 0xeb9310b185455f863f526dab3d245809f6854b4dMember Posts: 769 ✭✭✭
    some pools require it, otherwise you can just leave it blank
  • OrangeBubblegumOrangeBubblegum Member Posts: 52
    edited June 2016
    Still seems to freeze.

    Ive got another system with two 380s that is running well, but that has all windows updates.

    The one that is crashing only has sp1 + a few. So Ill get all updates done and see if that helps.

    Ive got the VS redistributables, do you think I should get a full install done?
  • ma68546ma68546 Member Posts: 9
    edited June 2016
    You only need VS Redist for running the Ethminer.
    You DONOT need the Visual Studio IDE at all for running the genoil-miner if that is your question.

    can you supply us some pictures of your rig to give us a better picture?

    Is the system crashing (black /blue screen, no Keyboard-LED when you press the NUM key?)
    Or is only Ethminer crashing?

    ..
    how are your updates doing?
  • OrangeBubblegumOrangeBubblegum Member Posts: 52
    edited June 2016
    @ma68546 : Okay great, I wont install it then.

    Sorry if I didnt make this clear, the entire rig will freeze (windows becomes unresponsive). There is no black or blue screen.

    Havent finished with Windows updates so far, but they will all be finished installing today. Using WSUS offline to speed things up.

    Will post some pictures up in a couple of hours.

    Its not only ethminer that is crashing, I can get ethminer running fine. Its the entire system that is freezing (windows unresponsive).

    I got 1.1.7 running, but the system still freezes after a while.
  • SmokyishSmokyish ✭✭ Member Posts: 203 ✭✭
    How's your cards/systems temperatures?
  • OrangeBubblegumOrangeBubblegum Member Posts: 52
    CPU stays below 55C, northbridge below 45C (will double check this one), GPUs get to 72C max, but usually below 70C.
  • OrangeBubblegumOrangeBubblegum Member Posts: 52
    Yesterday finally managed to fix everything. Before I start putting in the USB riser I updated all the bios's on 2 rigs, but were having problems with shutting down and turning off. Before that they were fine. Turns out when I updated the bios on both machines, the ASUS motherboards decided to overclock themselves. Bloody hell, what a pain in the ass.

    Anyway, 3 rigs ups and running now, total 7 x 380 and 1 x 280X. Ive drilled the hard drive cages out of 3 cases to make room for extra video cards. Ive got room for 4 more 380s.

    Running genoil 1.1.5. Any advantages to using 1.1.7?

Sign In or Register to comment.