Unable to contact Ethereum node

NosykaaNosykaa Member Posts: 4
Hi,

I have an issue when I want to deploy my Dapp on the server. This is the procedure that I have done :
  • In a terminal : geth --port 30301 --rpcport 8545 --dev console
  • In Mix Deploy>Deploy to network
  • In the field "Ethereum node URL" : I put http://localhost:30301
But Mix still indicate "unable to contact Ethereum node on http://localhost:30301 "
Here there is the nodeInfo of my Ethereum node :



Can someone know what is the URL of my node or why Mix can't connect to it ?

Thanks

Comments

  • YannYann Member Posts: 40
    hi,
    You should put 8545 for the port.
    Also you might need to add the option --rpc also.
  • NosykaaNosykaa Member Posts: 4
    It works!!

    Thanks a lot.

    May I ask another question.
    My account doesn't have any ether, but I want to deploy my Dapps on my private test blockChain. Do you know if I need any ether ? and how can I get some if I don't want to connect myself to the public blockChain ?
  • NosykaaNosykaa Member Posts: 4
    I find it.
    I got ether by mining into my private chain.
  • YannYann Member Posts: 40
    Feel free to join the gitter channel if you have any questions:
    https://gitter.im/ethereum/mix
    https://gitter.im/ethereum/mist
    .. and so on
  • pietdionpietdion Member Posts: 10
    I too cannot deploy to network.
    Start geth (without parameters).
    Geth reports its "listening" on 30301.

    I then start Mix and then Deploy>Deploy to Network. The dialog box reports:

    "unable to contact Ethereum node on http://localhost:30301"

    Tried altering 30301 to 8585, 30303 etc. No success.

    When I edit the "ethereum node url" box, the red error report also updates instantly.

    Running Mix on MacOSX.

    Any pointers gratefully received.
  • YannYann Member Posts: 40
    You have to run geth using the -rpcto enable the rpc server
  • pietdionpietdion Member Posts: 10
    Thanks for your help but no luck.
    I start geth with the rpc option:

    geth -rpc

    It starts ok eventually reporting:

    .... server.go:552] Listening on [::]:30303

    I then start Mix and attempt to deploy contract.
    In the "Ethereum node url" box I enter

    http://localhost:30303

    No matter what I enter, underneath the entry box it reports (in red)

    "Unable to connect to Ethereum node ...."

    where .... is whatever entered. Interestingly as I edit the entry box
    the red error message updates simultaneously. There does not
    appear to be any attempt to connect to anything even after pressing the
    reset button.
  • Vivi127Vivi127 Member Posts: 27
    pietdion said:

    Thanks for your help but no luck.
    I start geth with the rpc option:

    geth -rpc

    It starts ok eventually reporting:

    .... server.go:552] Listening on [::]:30303

    I then start Mix and attempt to deploy contract.
    In the "Ethereum node url" box I enter

    http://localhost:30303

    No matter what I enter, underneath the entry box it reports (in red)

    "Unable to connect to Ethereum node ...."

    where .... is whatever entered. Interestingly as I edit the entry box
    the red error message updates simultaneously. There does not
    appear to be any attempt to connect to anything even after pressing the
    reset button.

    I have the exact same issue :/
  • pietdionpietdion Member Posts: 10
    More details on the problems I have trying "deploy to network" in Mix
    on a Mac OSX computer.

    Mix crashes at different points. I cannot reproduce the exact point
    at which Mix crashes.

    1. Have to restart computer to get a "clean" state
    2. Start geth in terminal

    geth --rpc --rpcport 8585

    3. Wait till geth starts updating blocks
    4. Start Mix, point to right contract
    5. >Deploy >Deploy to network.
    6. In first box ensure it says the 8585 port
    7. Maybe have to redo steps 1 - 5
    8. Again try and deploy to network hoping port is configured ok.
    9. Now can start to deploy by moving to next dialog box
    10. Shifting away from this dialog box caused Mix to crash.
    11. Restart at 1 etc etc

    Most of the time Mix crashes immediately when going to >Deploy.
    Sometime not. Sometime I can get to second screen of Deploy.
    But when I move away from that screen it always crashes.

    Any help much appreciated.
  • pietdionpietdion Member Posts: 10
    I appear to have circumvented the problem and can now deploy contracts to the network. The issue is that I had a lot of contract files. By cleaning out all but one file and restarting, everything works smoothly.

    For the record, the setup I use on a Mac OSX is to use in terminal

    geth --rpc --rpcport 8585

    and then Mix>Deploy is pointing to node 8585.

    My moto now is " keep things simple/minimal".

Sign In or Register to comment.