POC3 Alethzero on Windows just consumes memory, no gui

Previous versions worked, I'm not sure what is wrong here. I've gotten past all the errors about missing DLLs by installing various MinGW packages, but when I start up alethzero.exe the only thing that happens is that the process gobbles up more and more memory without spawning a GUI. Do I just need to wait longer? Is there something wrong with it?


  • comtechnetcomtechnet Member Posts: 57
    The HEAD version required a removal of the ~./ethereum file.

    Maybe the POC3 has the same requirement?

    When I update the HEAD version yesterday morning - I had a similar result - the GUI never came up and it (the process) seemed to be in an infinite loop. No - you will have to kill it or do a hard boot. rm the ./ethereum file see the build notes for the HEAD or POC3, then it might run - MINE DID
  • aatkinaatkin Member Posts: 75 ✭✭
    I get the same thing (C++ Win64 client). The process alethzero.exe ramps up to using 250mb of RAM. No GUI. If I run either of the other 2 files, e.g. eth.exe I get the missing winthreadp-1.dll error.

    POC 2 worked fine and I did delete all folders related to POC2 before running POC3.

    Strange things about POC2 were a slow response time to the GUI, and while I was able to mine blocks for Finney and even insert a simple contract, once I stopped mining and restarted the client the other peers didn't seem to accept my blocks and rolled it back to block 17200 whereas I had 20 more blocks or so after mining for 3 hours.
  • OperatrOperatr Member Posts: 4
    Same for me with POC 3 (win7 pro x64). I watched it consume memory for quite some time until it finally bottomed out (low memory warning), no GUI appearing.

    I got the same warnings for the dependency DLLs, which I installed a package that seemed to correct it, but Eth did the same thing as AlethZero.

    Nothing quite like software Alpha :D
  • aatkinaatkin Member Posts: 75 ✭✭
    There seems to be a new Win64 C++ build out that works better. I did install MinGW and put C:\MinGW\bin in my Path environment variable (control panel->system->advanced)
  • StephanTualStephanTual London, EnglandMember, Moderator Posts: 1,282 mod
    POC3 vs2013 3.11 got updated again this morning.
  • OperatrOperatr Member Posts: 4
    Works like a charm now, Alethzero came right up
Sign In or Register to comment.