GTX 980 getting ~19 mh/s is this good? was hoping 20+

xiTzTHATGaMeRxxiTzTHATGaMeRx Member Posts: 34
edited March 2016 in Mining
ive been mining for a couple days now with a windforce gtx 980 which has 3 fans. It was my gaming gpu until I heard about ethereum lol. Just wondering is 19 mh/s for this card good? I thought itd atleast hit over 20 mh/s. If anyone else with a gtx 980 is hitting higher numbers please share your overclock below and keep in mind mine is not watercooled so it cant get too crazy but does have 3 fans which helps a bit. I'd like to squeeze out as much ethereum as I can cause I have a mining buuld in mind and don't have the money so I'm relying on etherum to pay for a lot of it.

Comments

  • workwork Member Posts: 2,084 ✭✭✭✭
    It might help if you start by explaining what you have now - what genoil version, what command-line options, what drivers, what OS are you running?
  • xiTzTHATGaMeRxxiTzTHATGaMeRx Member Posts: 34
    sorry im such a noob cause I started 2 days ago but the pool I use is nanopool, the command I use is ethminer.exe -F http://us-west1.nanopool.org:8888/0xC2De3f5FcA3F18c3801De5F311Eb63C552FA0272/gtx980 -G, what is genoil and how do you find the version you are running?, I use GeForce driver 347.52, im on windows 10. I hope this info or some of this info helps im a complete noob to mining lol.
  • blueboxbluebox Member Posts: 181 ✭✭
    edited March 2016
    Needs to be set in P0 (compute) state; ethminer doesn't kick it into this mode, your card will stay in P2 unless you force it with nvidia-smi, which is in C:\Program Files\Nvidia Corporation\NVSMI.

    Run this in cmd in admin mode:
    nvidia-smi -q -d SUPPORTED_CLOCKS | more
    (that's a pipe before more)

    Take the top number for memory, something like 3505 (GTX970), and the first number for graphics, something like 1531. Again in admin mode, enter your numbers in this format:

    nvidia-smi -ac 3505,1531

    You're card's memory will now run in compute mode (P0).

    After that, you can add more mem/core clock speed with afterburner. You might be able to go up to 4000MHz, but likely will have gpu errors on submits, so start at 3700 (+200 in afterburner) and go from there.

    With 3700/1430, I get about 21-22MH/s on a GTX970.
  • retherrether Member Posts: 258 ✭✭
    bluebox said:

    Needs to be set in P0 (compute) state; ethminer doesn't kick it into this mode, your card will stay in P2 unless you force it with nvidia-smi, which is in C:\Program Files\Nvidia Corporation\NVSMI.

    Run this in cmd in admin mode:
    nvidia-smi -q -d SUPPORTED_CLOCKS | more
    (that's a pipe before more)

    Take the top number for memory, something like 3505 (GTX970), and the first number for graphics, something like 1531. Again in admin mode, enter your numbers in this format:

    nvidia-smi -ac 3505,1531

    You're card's memory will now run in compute mode (P0).

    After that, you can add more mem/core clock speed with afterburner. You might be able to go up to 4000MHz, but likely will have gpu errors on submits, so start at 3700 (+200 in afterburner) and go from there.

    With 3700/1430, I get about 21-22MH/s on a GTX970.

    I get the error "nvidia-smi failed to initialize nvml" when I try to run nvidia-smi...any idea why? This is on a GTX 760.
  • GenoilGenoil 0xeb9310b185455f863f526dab3d245809f6854b4dMember Posts: 769 ✭✭✭
    @bluebox if I put my 970 (Asus Strix) into P0 mode using max cloxks as reported by smi, GPU-Z says it pulls over 100% TDP. Isn't that unhealty?
  • blueboxbluebox Member Posts: 181 ✭✭
    edited March 2016
    @Genoil It's only unhealthy if the temps remain elevated for extended periods, obviously when mining. I ramp the fans with afterburner to keep them under 70°C, more like 65° with about 60-70% fan speed (I have EVGA SSC's). These cards only report 70-80% TDP at these settings with EVGA's GPU monitoring software (OCScanner), so it must vary from model to model, which software is used, etc. I've heard GPU-Z misrepresents some things so I don't use it. Grab something like HWMonitor to track actual V/A/W on the rails, and calculate from the manufacturer's max power draw; that's your real "TDP".

    EDIT I should mention but you probably already know, GPU manufacturers take great liberties with what they define as "TDP", it's not the same across the board and they've all done their own thing. It's not like CPU TDP, a well-defined standard that data center server manufacturers adhere to. /EDIT

    Just as important that no-one seems to mention; when drawing the extra power, keep your PSU cool too. Many times the stock fan speed on them is too low and temps run 80° or higher — that wouldn't be too healthy either. :)
  • xiTzTHATGaMeRxxiTzTHATGaMeRx Member Posts: 34
    Finally decided to try this cause i wasnt sure what may happen but i get this error :/ Setting applications clock is not supported for GPU, Treating as warning and moving on.
  • blueboxbluebox Member Posts: 181 ✭✭
    edited March 2016
    @xiTzTHATGaMeRx I would think all GTX980's should be able to set the memory; make sure you're running the nvidia-smi -ac command in an admin mode console (run as administrator).
  • dominusdominus Member Posts: 36
    Genoil said:

    @bluebox if I put my 970 (Asus Strix) into P0 mode using max cloxks as reported by smi, GPU-Z says it pulls over 100% TDP. Isn't that unhealty?

    No worries, especially not for eth mining. Just pay attention to the temperatures. It would be very nice keeping them below 70° or still ok keeping them under 75°. The TDP limit is the first thing I max out on the asus strix 970. It rises the max power from 165W(100%) to 200W(120%).
    I have 3 of those cards since ~8months, bought all 2nd handed. All are stable at least at gpu 1450Mhz/mem 3850 Mhz. All my maxwells are doing at least 1400Mhz on core.

    Ontopic:
    My gigabyte G1 980 is set to 1434/3953, fan 60, temp <70°C hashing at ~23.7Mh
    The G1 970 at 1567/3953 hashing with exactly the same numbers as 980 if not a little bit more
    The asus strix 970 at 1466/3824 hashing almost the same...a bit over 23Mh
    960 at 1414/3801 doing around 11.5-12Mh
    win7x64, genoil's miner
  • 3esmit3esmit Member Posts: 23
    edited March 2016
    I've compiled Genoil github version in Ubuntu 14.04.02 LTS, running two instances - one 'MSI GTX 970 GAMING 4G' getting 17~MH/s (in P2) and the other is a 'Power Color Radeon R7 370 4GB' getting 14MH/s.
    It would be nice to have tips in boosting the cards, like that mining hardware list someone did.

    Edit: take a look here http://62.212.74.86/~mining/list/index.php?brand=nvidia

    ethminer -U --dag-dir /home/ricardo/.ethash1 -F http://127.0.0.1:8080/r1 --cuda-grid-size 4096


  • blueboxbluebox Member Posts: 181 ✭✭
    edited March 2016
    EDIT: Sheesh, just realized I already posted this above... been a long weekend so far. :D

    @3esmit For the 970 run
    sudo nvidia-smi -q -d SUPPORTED_CLOCKS
    Take the first memory number (something like 3505) and the first graphics number (something like 1531), those numbers are from my EVGA SSC 970.
    Then run with your numbers:
    sudo nvidia-smi -ac 3505,1531
    Instant P0 state, should get 19-20MH without touching the core clocks. :)

    For the R7 you'll have to ask someone else how to set the clocks using aticonfig or whatever on linux, but it can be done. Probably max the memory at 1500MHz, core at 1550MHz or less for stability. Should be good for 15.5MH or so, that's what I get (MSI gaming 4GB).
  • 3esmit3esmit Member Posts: 23
    @bluebox Sadly this don't happens.
    I think there is a problem with my GPU, when I run the command it does not change anything in the hashrate, even if I change it to the lowest clock in the SUPPORTED_CLOCKS list the hashrate stays the same. Also, if I touch the -ac command nvidia-smi changes to P0, regardless of the clock choosen (higest or lowest)...



    Seems like the driver is buggy. In Windows I had troubles with overclocking in some drivers versions, maybe I can find a driver that works for me.
    My GPU is MSI GTX 970 Gaming G4.
  • blueboxbluebox Member Posts: 181 ✭✭
    @3esmit

    You don't list any before/after hashrates, or at least show terminal output of the miner...

    Step 1: Stop all running miners on the system.
    Step 2: Set the clocks with the nvidia-smi -ac ####,#### command as before
    Step 3: Check that the clocks are set by running nvidia-smi -q -d SUPPORTED_CLOCKS |more and seeing if the mem and first graphics values have changed to reflect your numbers
    Step 4: Run the miner, check hashrate against previous.

    In windows 7 the change is immediate, perhaps it isn't on linux but I'd doubt that.

    It isn't the driver, it's not buggy on linux — but it is a major problem on windows 8.1 and 10 (WDDM2).
  • 3esmit3esmit Member Posts: 23
    edited March 2016
    Lowest clocks test... (should get lower hashrate)


    p0 state, highest clocks...


    reset it to defaults...

  • Pminer0208Pminer0208 Member Posts: 5
    edited December 2016
    Mining with 6 bios-flashed Gigabyte 970 SC 4G on windows 7 64-bit

  • joschemlajoschemla Member Posts: 1
    Hi,
    I am mining at 3-4MH/s with a GTX 980, on windows 10 with CUDA 8 and latest drivers, using genoil ethminer and minergate pool. What is your advice to get to 22MH/s ? Use a live USB key with Ubuntu 16.04 and NVidia drivers to mine ? And using another pool will help ?
    Thx in dvance, Jonathan
Sign In or Register to comment.