Can't run go-ethereum on Mac OS X

jayhall49jayhall49 Member Posts: 4
edited February 2014 in Geth - Go Implementation
This is probably something simple. I downloaded and installed go-ethereum from github following the instructions on the wiki. No problems. But when I try to run "go-ethereum -m" I'm getting a bash error that the go-ethereum command is not found. My GOPATH is set to ~/go and the directory structure looks ok:

------ /
------------------ethchain.a, ethutil.a, ethwire.a

I first tried executing 'go-ethereum -m' from various directories in the directory tree and with trying absolute and relative path names for where I thought the command might be. No luck.

Then, not seeing it in the ~pkg directory, I thought that maybe it needs to be built/installed.

If I run 'go list' it recognizes that go-ethereum is a package.

But when I try 'go install' I get an error:

src/ not enough arguments in call to db.db.NewIterator

I'm using go version 1.2. Any ideas?


Sign In or Register to comment.