Fluctuating GPU usage (0%-100% every few seconds)

2»

Comments

  • happytreefriendshappytreefriends Member Posts: 537 ✭✭✭
    yes, it's set at 256. (al my cards are r7-370,R9-280/290,HD7990 and R9-390's.
  • dlehenkydlehenky Member Posts: 2,249 ✭✭✭✭
    @happytreefriends If cl-local-work is 256, you've essentially multiplied cl-global-work by 4 (256/64, 64 being the default local work size). If you're using 8192 for cl-global-work, the net result is a global work size of 2097152, or a kernel that will run close to 85 ms @ 25 mh/s. Using cl-global-work = 32768, without setting cl-local-work, would have exactly the same effect.
  • happytreefriendshappytreefriends Member Posts: 537 ✭✭✭
    edited March 2016
    It doesn't. When I set cl-local-work to 32768, it gives me very random hash rates, sometimes 2x normal rates, then down to 1/2. It also gives me '0' hash rates a few times per block.

    When I set it back to 8192, everything is normal again and much more stable.

    I actually raised it up on all my rigs to 11000, and it seems to be giving me a few extra % MH.
  • dlehenkydlehenky Member Posts: 2,249 ✭✭✭✭
    @happytreefriends Do you mean -cl-global-work? 32768 for -cl-local-work is not a legal value in AMD OpenCL. The Ethereum code checks it, and won't use a value above 256, which is enforced by the AMD OpenCL runtime, anyway.
  • happytreefriendshappytreefriends Member Posts: 537 ✭✭✭
    Yes I meant global-work. Sorry.
  • dlehenkydlehenky Member Posts: 2,249 ✭✭✭✭
    @happytreefriends I'm not sure what you were referring to in your previous post "It doesn't"? All I said was using cl-global-work 8192 and cl-local-work 256 is the same as using cl-global-work 32768 by itself. I didn't say that would be stable for you. I run mine at 16384, but I believe I have a higher hash rate and faster CPU than your current configuration. The value I use gives me a kernel runtime of 40 ms.
  • happytreefriendshappytreefriends Member Posts: 537 ✭✭✭
    I just go by the #'s.
    So me running with --cl-local-work 256 --cl-global-work 8192 is the same as --cl-local-work 64 --cl-global-work 32768 ? Man this stuff is confussing. LOL

    That explains why if I set local=256 and global=32768 it is highly unstable, as it's now 4x my normal settings.

    I have been playing with the numbers and at least on my 4x R9-390/x gpu rigs running on AMD FX 6-core 6300CPUs --cl-local-work 256 --cl-global-work 8192 seems to work best.

  • dlehenkydlehenky Member Posts: 2,249 ✭✭✭✭
    @happytreefriends "So me running with --cl-local-work 256 --cl-global-work 8192 is the same as --cl-local-work 64 --cl-global-work 32768 ? Man this stuff is confussing. LOL"

    Yes, that is correct, but there's no need for cl-local-work 64, since that it is the default setting.
  • happytreefriendshappytreefriends Member Posts: 537 ✭✭✭
    Got it.

    Also looks like the R7 based cards have a hard time handling global=16384 numbers. Only R9 cards are fine with it. Otherwise the hash rate is fluctuating with 100% ups and downs.
  • dlehenkydlehenky Member Posts: 2,249 ✭✭✭✭
    @happytreefriends Are the R7 cards OpenCL 1.1, by chance, rather than 1.2?
  • happytreefriendshappytreefriends Member Posts: 537 ✭✭✭
    edited March 2016
    It's OpenCL 2.0 same as the R9-390 models.
Sign In or Register to comment.