miner stops

ericeric Member Posts: 76
i'm running 2 r9-280x toxic on windows 10. connecting via team viewer. i just noticed after 5 minutes the miner stops but doesn't close the cmd. when 1 press any key it resumes. can any 1 help me

Comments

  • HelioxHeliox Member, Moderator Posts: 634 mod
    clock your card down. test again.
  • ericeric Member Posts: 76
    i have no other settings. just this

    ethminer.exe -G -F http://eth-eu.dwarfpool.com:80/YOUR_WALLET

    the problem didn't occur from 10pm to 1pm and now its back.
  • fknight8fknight8 Member Posts: 1
    Hi Eric
    I have a similar configuration (recent upgrade to Windows 10, Team Viewer remote control and HD 7970) and I mine on Suprnova.
    I have what seems to be a similar problem to yours, i.e. hashing goes to down to 0 H/s erratically then completely stops but Ethminer doesn't actually crash and the cmd window stays open. This can happen after 1 minute or 1 day! Do you see a Windows 10 pop-up message in the bottom right-hand corner, saying that the driver has crashed but recovered? This is what kills the hashing for me.

    I've tried everything I could:
    • all Radeon drivers
    • registry clean-ups
    • reboots
    • not running any other "foreground" application
    • download Ethminer from different sources
    • mining on different pools
    • running at standard clock
    • overclocking
    • you name it...
    I've now tried pressing a key but the process doesn't restart.

    The problem is that it is impossible to pinpoint what fails and why, as there are just too many hardware/software elements in the process.
    Saying that, after days of starts and stops Ethminer is now behaving itself for some unknown reason, although it did stop while I was writing this post...

    I did find a great script on the net that somewhat helps me in mitigating the issue, in that it automatically restarts Ethminer and an interval I can specify. I've set it to 1 hour (3,600 seconds, see below) but you can change this to whatever you want.
    What's good is that you just need to create a new text, copy the content below, change pool address and any other parameter you wish, then save as a .bat in the same folder as Ethminer!
    Not sure this is going to help in your case, but could be useful if you can keep Ethminer going beyond 5 minutes!

    @echo off

    echo -------------------------------------------------------------------
    echo Simple script to restart your miner software after a period of time
    echo -------------------------------------------------------------------
    echo:

    set executable=ethminer.exe
    set commandline= -G --opencl-device 0 -F http://xxxxxxxxxxxxxx

    set runforseconds=3600
    set restartinseconds=10
    set /a counter=0
    timeout 15
    setx GPU_MAX_ALLOC_PERCENT 100
    setx GPU_USE_SYNC_OBJECTS 1
    setx GPU_MAX_HEAP_SIZE 100
    :start
    start "ETHMiner" %executable% %commandline%
    echo:
    echo The software will run for %runforseconds% seconds
    timeout %runforseconds%
    taskkill /f /im %executable%
    echo:
    echo Restarting the software in %restartinseconds% seconds (%counter%)
    timeout %restartinseconds%
    set /a counter+=1
    echo:
    echo:
    goto start
  • ericeric Member Posts: 76
    @fknight8 thanks for the tip. my miner are now working fine. i haven't seen any notification that the driver crashed.
  • dlehenkydlehenky Member Posts: 2,249 ✭✭✭✭
    @eric I have no idea if this wis the cause of your problem, but are you turning the fans on your GPU up to 100%? Sounds as though they could be overheating and going through thermal shutdown. You should always manually set your fans to 100% before you start to mine.

    -Best Care
    David
Sign In or Register to comment.