Transactions not going through and update question

Several recent transactions attempts are not making it to the blockchain while other transactions in the same time period have worked without any trouble. Is this possibly a problem that will be resolved by updating to the latest version of geth and is there potential for problems accessing my accounts if I do update using the bash curl script? Would it be more advisable to build from the latest source in order to maintain my access to the (sort of) functional version that I am currently running?
For what it's worth, I have backed up my keystore folder and passwords for my accounts.


  • rtaylorrtaylor Member Posts: 5
    Update: After updating GETH to v1.1.0 and attempting another transaction, the same result occurred. Txid was returned in the console but never made it to the blockchain.
    Does anyone know why some transactions would go through and others would not?
  • dlehenkydlehenky Member Posts: 2,249 ✭✭✭✭
    @rtaylor Most folks are running much later versions of 'geth' than v1.1.0. I've been running v1.3.3 for quite a long time without any transaction issues. v1.3.3 is the latest release version. If you go to you can see the distribution of versions being used on the Ethereum network (Tools->Nodes). Basically, no one is running a 'geth' version as old as you are. You might want to get current with the latest release (stable) update.

    -Best Care
  • rtaylorrtaylor Member Posts: 5
    Thanks for the feedback, @dlehenky . I've updated to 'geth' v1.3.3 and attempted another transaction but it also did not get picked up. Any idea why this would happen or how I can find the solution?
  • dlehenkydlehenky Member Posts: 2,249 ✭✭✭✭
    @rtaylor Well, this is just a shot in the dark, and I know it's not pretty, but you might try downloading the blockchain from scratch with the newer 'geth' version you have. Otherwise, all I can suggest is that the transactions are not properly formed. Sorry I can't be of more help.
  • rtaylorrtaylor Member Posts: 5
    Fantastic! I downloaded the blockchain from scratch and order has been restored. Thanks, again, @dlehenky!
  • dlehenkydlehenky Member Posts: 2,249 ✭✭✭✭
    @rtaylor Hooray! That's great. Happy mining!
Sign In or Register to comment.