Alethzero on Windows 7 is blowing up when trying to mine

oliverkxoliverkx Member Posts: 85
I followed the instructions on:
https://github.com/ethereum/cpp-ethereum/wiki/Building-on-Windows
After resolving some path issues with qt, everything compiled in VS 2013.

I was able to launch the Alethzero UI, but clicking on mining triggers the following error:
Unhandled exception at 0x00000001404E7E07 in alethzero.exe: 0xC0000005: Access violation reading location 0x0000000000000000.

The call stack points to the following line:
alethzero.exe!dev::eth::Ethash::CPUMiner::workLoop() Line 142 C++
ethashReturn = ethash_full_compute(dag->full, *(ethash_h256_t*)w.headerHash.data(), tryNonce);

Here is what is visible in the DOS box that runs next to the UI:

--------------------- Launch AlethZero.exe

(skipping over initial stuff, which looks ok - no errors)
eth Network protocol version: 60
Client database version: 11785
N i 14:26:41|main Id: ##345cface…
i 14:26:41|main Opened blockchain DB. Latest: #fd4af92a…
i 14:26:41|main Opened state DB.
D 14:26:42|eth startedWorking()
QtWebEngineProcess not found at location C:/cpp-ethereum/build/alethzero/Debug/bin\QtWebEngineProcess.exe. Trying fallback path...
qt.network.ssl: QSslSocket: cannot resolve TLSv1_1_client_method
qt.network.ssl: QSslSocket: cannot resolve TLSv1_2_client_method
qt.network.ssl: QSslSocket: cannot resolve TLSv1_1_server_method
qt.network.ssl: QSslSocket: cannot resolve TLSv1_2_server_method
qt.network.ssl: QSslSocket: cannot resolve SSL_select_next_proto
qt.network.ssl: QSslSocket: cannot resolve SSL_CTX_set_next_proto_select_cb
qt.network.ssl: QSslSocket: cannot resolve SSL_get0_next_proto_negotiated
! 14:26:48|main void __cdecl Main::refreshBlockChain(void) 0.013 s
D 14:26:48|main newBlock watch ID: 0
D 14:26:48|main newPending watch ID: 1
D 14:26:48|main !!! Main: uninstalling watch 4294967295
! 14:26:48|main void __cdecl Main::refreshBlockChain(void) 0.009 s
D 14:26:48|main !!! Main: uninstalling watch 4294967295
D 14:26:48|main !!! Main: uninstalling watch 4294967295

--------------------- Start Mining

i 14:28:53|main Post state changed: Restarting mining...
! 14:28:53|main working 0 s
! 14:28:53|main post 0 s
D 14:28:53|main pause took 0
D 14:28:53|main kickOff took 0.016
D 14:28:53|main pause took 0
D 14:28:53|main kickOff took 0.015
D 14:28:53|main pause took 0
D 14:28:53|main kickOff took 0.016
D 14:28:53|main pause took 0
D 14:28:53|main kickOff took 0.016
D 14:28:53|main pause took 0
D 14:28:53|main kickOff took 0.015
D 14:28:53|main pause took 0
D 14:28:53|main kickOff took 0.016
D 14:28:53|main pause took 0
D 14:28:53|main kickOff took 0.015
D 14:28:53|main pause took 0
D 14:28:53|main kickOff took 0.016

--------------------- BLOW UP

I tried adding the path to QtWebEngineProcess.exe to the Windows system path variable, but that didn't help.

Any help would be greatly appreciated!

Thanks,

Oliver.

Best Answer

Answers

  • Maren85Maren85 Member Posts: 41
    It's what is technically known as knackered, nothing you've done, everyone is in the same boat. It's been like that for a few weeks, some of the older versions work though. If you look on the site, any of the versions above 50mb work, less dont.
  • oliverkxoliverkx Member Posts: 85
    Good to know. Thanks for the help!
  • wynandjordaanwynandjordaan Member Posts: 1
    It seems like the versions thats over 50mb on this site https://build.ethdev.com/builds/Windows C++ master branch/ is also not working 100%.
  • PansyfaustPansyfaust Member Posts: 29
    I'm having the same issue on my Alethzero, version 1.0.1.

    version: 12041 QtWebEngineProcess not found at location C:/Program Files/Ethereum 1.0.0/Release/bin\QtWebEngineProcess.exe. Trying fallback path... qt.network.ssl: QSslSocket: cannot resolve TLSv1_1_client_method qt.network.ssl: QSslSocket: cannot resolve TLSv1_2_client_method qt.network.ssl: QSslSocket: cannot resolve TLSv1_1_server_method qt.network.ssl: QSslSocket: cannot resolve TLSv1_2_server_method qt.network.ssl: QSslSocket: cannot resolve SSL_select_next_proto qt.network.ssl: QSslSocket: cannot resolve SSL_CTX_set_next_proto_select_cb qt.network.ssl: QSslSocket: cannot resolve SSL_get0_next_proto_negotiated QObject::connect: No such signal dev::aleth::Aleth::knownAddressesChanged(AccountNamer) QObject::connect: (receiver name: 'Main') QObject::connect: No such signal dev::aleth::Aleth::addressNamesChanged(AccountNamer) QObject::connect: (receiver name: 'Main')
Sign In or Register to comment.