How to install Solidity Compiler on Windows?

ivoronlineivoronline Member Posts: 21
I have tried using "cinst -pre solC-stable" as described in official tutorial but I get following error
I:\Windows\system32>cinst -pre solC-stable
Chocolatey v0.9.9.8
Installing the following packages:
By installing you accept licenses for the packages.
solC-stable not installed. The package was not found with the source(s) listed.
 If you specified a particular version and are receiving this message, it is possible that the pac
kage name exists but the version does not.
 Version: ""
 Source(s): ""

Chocolatey installed 0/1 package(s). 1 package(s) failed.
 See the log for details (G:\Installed\Chocolatey\logs\chocolatey.log).
 - solC-stable
Instructions also say that it should come with GETH but when I use "eth.getCompilers()" I get empty string instead of ['Solidity'].


  • ivoronlineivoronline Member Posts: 21
    edited September 2015
    I have installed SOLC using C++ master branch but I would still like to know how to install it using chocolatey.

    Also every time I connect to Private Network I have to reconnect GETH with SOLC using or else I get [""]
    geth --genesis G:\Temp\Ethereum\genesis_block2.json --datadir G:\Temp\Ethereum\datadir --networkid 123 --nodiscover --maxpeers 0 console
    > admin.setSolc("I:/Installed/Programming/Ethereum 0.9.41/Release/solc.exe");
    > eth.getCompilers();	
  • rfikkirfikki Palm Beach, FloridaMember Posts: 26
    --solc "PATH-TO\Ethereum 0.9.41\Release\solc.exe"
    Add this to your geth startup command you list above but make sure you set your path properly
  • ivoronlineivoronline Member Posts: 21
    Thanks. But is it possible to put that in some configuration file so that I don't have to relink GET with SOLC every time I connect to network? Or in Environment Variable?
  • JasonJason Member Posts: 12
    @ivoronline please how did you install SOLC using C++ master branch but I would still ??? I have the same problem on windows ,I need the deatails
  • ivoronlineivoronline Member Posts: 21
    edited September 2015
    You have to install ETH from C++ master branch/Ethereum-win64-latest.exe

    Then in isntallation directory you will see that you have solc.exe in directory
    I:\Installed\Programming\Ethereum 0.9.41\Release

    Then you link GETH to SOLC either through GETH command line

    geth --datadir G:\Temp\Ethereum\datadir --solc "I:/Installed/Programming/Ethereum 0.9.41/Release/solc.exe" 2>> G:\Temp\Ethereum\my.log console

    or in GETH console

    > admin.setSolc("I:/Installed/Programming/Ethereum 0.9.41/Release/solc.exe");
  • scbuergelscbuergel Member Posts: 15
    For some reason the install location that you mention does not have the most up to date version compared to other places. I am quite confused by the different releases but has an installer for Ethereum 1.0.1 while C++ master branch/Ethereum-win64-latest.exe only installs 0.9.41.
  • Forecast_CloudyForecast_Cloudy Member Posts: 5
    I am trying to create the greeter application/contract. I have linked solc.exe with geth:
    > admin.setSolc("C:/Ethereum/Ethereum 0.9.41/Release/solc.exe")
    I0112 20:30:57.976736 9576 solidity.go:114] solc, the solidity compiler commandline interface
    Version: 0.1.1-ed7a8a35/Release-Windows/msvc/JIT

    When I run eth.getCompilers() I still only get:
    which is what I get before running the admin.setSolc command.

    When I try to compile the greeterSource per the example I get the error:

    solc: no build results found
    at InvalidResponse (:-81662:-63)
    at send (:-156322:-63)
    at solidity (:-133322:-63)
    at :1:23

    Has anyone seen this error? Shouldn't I get something different the ["Solididty"] when I list the compilers?
  • goldhat00goldhat00 Member Posts: 4
    Im also having the same issue with solc and geth I cant even get ["Solididty"]
    I do get
    "solc, the solidity compiler commandline interface\r\nCersion: 0.1.1-cb61d09d/Release-Windows/msvc/JIT\R\n\npath: C:\\Ethereum 0.9.41\\Release\\solc.exe" in green then just updates blocks.
  • bmkrishbmkrish Member Posts: 14
    I am new to Ethereum.Setup the test net and try to compile the contract I am getting the below issue.

    solc: no build results found
    at InvalidResponse (:-81662:-63)
    at send (:-156322:-63)
    at solidity (:-133322:-63)
    at :1:23
    Please let me know how to resolve this issue.
Sign In or Register to comment.