Go-Ethereum 1.3.2 installation issues with Ubuntu 14.04LTS (Solved)

skithunoskithuno Member Posts: 74
edited November 2015 in Mining
Just pulled down that latest go-ethereum master commit so I can run 1.3.2 . However, getting the GPU mining for my AMD cards isn't working. When I run:
build/bin/geth gpubench
I get this response: GPU mining disabled. Set GO_OPENCL and re-build to enable.
How can I set GO_OPENCL?


export GO_OPENCL=true
make geth
build/bin/geth -maxpeers '100' -mine -minergpus '0' -autodag console

This series of commands successfully allowed GPU mining.
Post edited by skithuno on


  • ZomiZomi Member Posts: 10
    Good morning. I'm trying to undermine in ubuntu, because Windows does not throw all my gpu mhash r7 370.

    I have this problem.
    Issued the command to undermine and throws me.

    GPU mining disabled. September GO_OPENCL and re-build to enable.

    And also I run this

    export GO_OPENCL = true

    export GPU_MAX_ALLOC_PERCENT = 95

    make geth

    and this throws me

    build / install -v env.sh go -ldflags '= -X main.gitCommit 5490437942967638bcc6198035315f6811febaa8' -tags OpenCL ./cmd/geth
    # github.com/Gustav-Simonsson/go-opencl/cl
    / Usr / bin / ld: you can not find -lOpenCL
    collect2: error: ld returned 1 exit status
    make: *** [geth] Error 2

    I have ubuntu 14.04 and follow up this guide http://spacience.blogspot.com/2015/11/gpu-mining-in-ethereum-1404-from-scratch.html

    I thank you support. Thank you!
Sign In or Register to comment.