Only 1 card mining..

ZapbbxZapbbx Member Posts: 10
edited September 2015 in Mining
I have several GPUs, they were mining fine over the last week, since the update however, only 1 card will mine..
Ubuntu 15.04

OS Reports:
:~$ sudo aticonfig --list-adapters

* 0. 01:00.0 AMD Radeon R9 200 Series
1. 02:00.0 AMD Radeon R9 200 Series
2. 03:00.0 AMD Radeon R9 200 Series
3. 05:00.0 AMD Radeon R9 200 Series
4. 06:00.0 AMD Radeon R9 200 Series

* - Default adapter

Terminal Miner #1:

:~$ export GPU_MAX_ALLOC_PERCENT=95
:~$ ethminer -G --opencl-device 0 --no-precompute

[OPENCL]:Found suitable OpenCL device [Pitcairn] with 1890582528 bytes of GPU memory
ℹ 21:52:36|gpuminer0 workLoop 0 #00000000… #6d29f6dd…
ℹ 21:52:36|gpuminer0 Initialising miner...
[OPENCL]:Using platform: AMD Accelerated Parallel Processing
[OPENCL]:Using device: Pitcairn(OpenCL 1.2 AMD-APP (1445.5))
[OPENCL]:Printing program log
[OPENCL]:LOOP UNROLL: pragma unroll (line 300)
Unrolled as requested!
LOOP UNROLL: pragma unroll (line 266)
Unrolled as requested!
LOOP UNROLL: pragma unroll (line 361)
Unrolled as requested!
LOOP UNROLL: pragma unroll (line 361)
Unrolled as requested!

[OPENCL]:Creating one big buffer for the DAG
[OPENCL]:Loading single big chunk kernels
[OPENCL]:Mapping one big chunk.
[OPENCL]:Creating buffer for header.
[OPENCL]:Creating mining buffer 0
[OPENCL]:Creating mining buffer 1
ℹ 21:53:10|gpuminer0 workLoop 1 #6d29f6dd… #6d29f6dd…
ℹ 21:53:10|gpuminer0 workLoop 1 #6d29f6dd… #6d29f6dd…

Terminal Miner #2

~$ export GPU_MAX_ALLOC_PERCENT=95
~$ ethminer -G --opencl-device 1 --no-precompute

[OPENCL]:OpenCL device Pitcairn has insufficient GPU memory.762314752 bytes of memory found < 1423739904 bytes of memory required
No GPU device with sufficient memory was found. Can't GPU mine. Remove the -G argument


Same for all devices:
~$ ethminer -G --opencl-device 2 --no-precompute

~$ ethminer -G --opencl-device 3 --no-precompute

~$ ethminer -G --opencl-device 4 --no-precompute

~$ ethminer -G --opencl-device 5 --no-precompute

This was working, what gives? ethminer doesnt see all the devices:

~$ ethminer --list-devices
[OPENCL]:
Listing OpenCL devices.
FORMAT: [deviceID] deviceName
[0] Pitcairn
CL_DEVICE_TYPE: GPU
CL_DEVICE_GLOBAL_MEM_SIZE: 762314752
CL_DEVICE_MAX_MEM_ALLOC_SIZE: 572784640
CL_DEVICE_MAX_WORK_GROUP_SIZE: 256

I just completely reinstalled Ubuntu, AMD drivers and all the clients trying to fix this, same issue.

Comments

Sign In or Register to comment.