Trouble with PATH windows installation

I'm trying to install in a Win 8.1 system following the instructions. But being far from an expert I am unsure of a step. I've been googling and looking here in the Ethereum forum but haven't zeroed in on anything that helped.
Setup environment paths

Add GOROOT pointed to c:\go and GOPATH to c:\godev (you are free to pick these paths).
Set PATH to %PATH%;%GOROOT%\bin;%GOPATH%\bin;c:\winbuilds\bin
I created a new System variable GOROOT with a value of f:\go (everything is getting installed on the F: drive)
and GOPATH with value of f:\godev

Currently there are preexisting variables called Path for both User and System but no variables named PATH. The Path variables existing don't include things like %PATH%. So I'm unsure what I should do. Should I;

- be making them User or System variables?
- be assuming that Path and PATH are interchangeable?
- be creating a new variable PATH and setting it to %PATH%;%GOROOT%\bin;%GOPATH%\bin;f:\winbuilds\bin
- be appending ;%PATH%;%GOROOT%\bin;%GOPATH%\bin;f:\winbuilds\bin onto the Path variable
- be doing something else altogether


Thanks

Comments

  • DaveHDaveH Member Posts: 42
    edited August 2015
    From memory when I did something similar you should be appending it to the existing Path variable.

    Pay attention to the format by which the other existing separate values are appended to the existing Path variable then add this %PATH%;%GOROOT%\bin;%GOPATH%\bin;c:\winbuilds\bin in the same manner.

    I think you might just need to put a semicolon (ie ; ) directly before it. So ;%PATH%;%GOROOT%\bin;%GOPATH%\bin;c:\winbuilds\bin and slap that directly on the end of the existing path variable.

    But double check.

    The command should then be recognised when you try to run it in the command line where previously you would have got some kind of command not recognised error.
  • DaveHDaveH Member Posts: 42
    edited August 2015
    If you haven't already seen this vid, this might help: https://youtube.com/watch?v=W9pg2FHeoq8
Sign In or Register to comment.