Success? Maybe... Alephzero progress and questions.

MilanMilan San Diego, CAMember Posts: 46
Started over from scratch, installing everything in Ubuntu 13.10 in a VirtualBox. I used the tarball. (downloaded this morning)

I had to do two things differently from the instructions:

1) I had to issue: "sudo apt-get install qt5-default" in order for alephzero to build.
2) I had to edit cpp-ethereum-poc-1/alephzero/alephzero.poc to correctle append "-poc-1" to "cpp-ethereum" in the INCLUDEPATH

alephzero runs, and here's what I tried so far:

Clicking Mine adds 1b wei, but doesn't seem to do anything beyond that.

Clicking Connect opens a window, in which I entered: "" this added a line to the leftmost pane, and I can see in the terminal that my client is attempting a bunch of additional connections. They either go to "Connected." or "Connection refused (connect: Connection timed out)" but no changes appear in the leftmost pane of the client gui. Also, the client greys out, or goes dim on me, and I can't interact with it any more.

Do I just need to wait for the connection attempts to finish? Or will my client perpetually try to find new connections? Is the greyed out window a problem? Should I eventually see more than one peer? (I've seen a ton of "Connected." messages in the terminal, but nothing in the client's gui window.


  • comtechnetcomtechnet Member Posts: 57
    Milan - I have similar results - I'm assuming that the "global Ethereum test network" means exactly that - that it remains a test network.

    My router does have uPNP and does allow the port 30303 to flow thru to my dynamic ip. I show 7 peers in the GUI client. Yes the terminal windows showed a bunch of activity, but now seems to have paused or stopped with no additional activity at the GUI (AlephZero) or the terminal.

    I'm at Ubuntu 13.10 and have built both the cpp command and GUI clients.

    I have not created my own local test network - nor have I built clients on multiple computers - just the one.

    So - I guess - this is it for now. I'll leave the machine running and connected this way to see if there is any further activity - it's been approx 30 minutes
  • allr1allr1 Member Posts: 8
    I tried to start the client via a remote ssh session and got a core dump also. However, I went directly to the machine and started Alephzero with no problem. I have started mining, now have 6 connections and 4 B wei. what is the wei? Is that what the ethereum coin will be referred to as? I also have just the one client. I have also sent out about 10,000 wei. One thing is that I don't really understand what is actually going on. Can anyone explain this mining process. The panels in Alephzero can go blank for awhile, then immediately populate. Sometimes for just a few seconds before going blank again, sometimes much longer.
  • MilanMilan San Diego, CAMember Posts: 46
    edited February 2014
    First off, 1 wei is 10^(-18) ether.

    1: wei
    10^3: (unspecified)
    10^6: (unspecified)
    10^9: (unspecified)
    10^12: szabo
    10^15: finney
    10^18: ether

    Alephzero has a graphical frontend, so it will be tougher to run over a non-windowed terminal. (Sorry if my terminology is weak here...)

    My panels don't wink in and out like you are describing, but for a while after I initially connect, the entire window does intermittently go grey and unresponsive. But if I wait it out it always seems to come back eventually.

    As far as mining goes, we're mining temporary test wei on the test network. None of this is for real yet.
  • allr1allr1 Member Posts: 8
    Milan - Thanks for the reply. I am just trying to understand what I am doing. I just tried the non-graphical window and as soon as I saw it would not work that way I went to the machine running Alephzero and started it there and have been mining going on 2 days now.
  • MilanMilan San Diego, CAMember Posts: 46
    Glad to hear it! Post your address and I'll send you some wei!
  • allr1allr1 Member Posts: 8
    My mining has not produced any results after the first day. Should I be concerned?
  • MilanMilan San Diego, CAMember Posts: 46
    24 hours? Yes, something is probably wrong. How many peers are listed at the lower right corner of your alephzero window? Is the "mine" button slightly darkened? What do the four panes in alephzero look like? Any entries? I've attached a screencap of my VirtualBox running alephzero, with the terminal peeking out underneath it. Hopefully that can be of some help to those wondering if their client is "working" or not.
  • Wil611Wil611 Member Posts: 77 ✭✭
    @Milan did you have to enable port forwarding in your virtualbox network settings?

    I am not getting peer connections.
  • MilanMilan San Diego, CAMember Posts: 46
    @Wil611 I did enable port forwarding in my VirtualBox settings, but I didn't try not doing so to see if it would work anyway. So I did, but I'm not sure whether I had to or not. I only know that with it enabled, things are working.

    Sorry for the imperfect answer...
  • Wil611Wil611 Member Posts: 77 ✭✭
    @Milan thank you I used telnet from outside my network and was able to connect to the client so I'm not sure what the problem is. I also noticed that your client does not have/show a UPNP button next to the NET button. When my client starts my terminal shows and error "No uPNP Device Found" so perhaps that is my issue.
  • MilanMilan San Diego, CAMember Posts: 46
    That's really weird. Can anyone shed some light on that difference in the above two screenshots?

    Specifically, what does the presence or absence of that "UPNP" button at the top left of the alephzero window indicate? Anyone know?
  • MilanMilan San Diego, CAMember Posts: 46
    Just for reference, here is what the terminal looks like when I first start alephzero:

    Opened blockchain db. Latest: 63063b5386494b0c5df247bdcb6a38f486aec1c02eb359147bdc4b0391ba8f02
    Address: = [LOCAL]
    Address: = [PEER]
    TB : init_upnp()
    Listening on local port 30303 (public:
    Mode: Full
    Initialising: latest=63063b5386494b0c5df247bdcb6a38f486aec1c02eb359147bdc4b0391ba8f02
    Attempting connection to
    38 | Hello: Ethereum(++)/v0.1 0x1 0
    38 | GetChain (1 hashes, 2048)
    38 | GetChain (128 max, from 0906dae3e53047ca76ed0603d48a9edadfd21f0efea5d5fd2437037c7cd1ad5a to 0906dae3e53047ca76ed0603d48a9edadfd21f0efea5d5fd2437037c7cd1ad5a)
    Requires 2 blocks from 2 to 0
  • allr1allr1 Member Posts: 8
    I am getting a message in my terminal window "Discordance over genesis block. Disconnected" Also seeing connection refused to different ip's on port 30303. I have 5 connections show in lower right corner. My "Mine" button is darkened as well as my "Net" button. I have no UPNP button. What is this enabling port forwarding in VirtualBox?
  • allr1allr1 Member Posts: 8
    My initial screen when starting the Alephzero client from the terminal window is similar to yours Milan.
  • comtechnetcomtechnet Member Posts: 57
    allr1 - there isn't a UPNP buttton in the GUI - that can be a feature of your router - if NOT - then you can port forward 30303 to your workstations ip (most routers have the port forwarding feature)
  • comtechnetcomtechnet Member Posts: 57
    allr1 - my bad - I see it now (the UPNP button on Wil611's snapshot - I DO NOT have that on my version (Implented 2/6/14) - My version of the GUI is AlephZero / v0.1 0x7 0
  • Wil611Wil611 Member Posts: 77 ✭✭
    it looks like there has been a name change from AlephZero to AlethZero as well.
  • StephanTualStephanTual London, EnglandMember, Moderator Posts: 1,282 mod
    edited February 2014
    Edit: it's not a typo, the client is indeed called AlethZero. It's been renamed.
    Post edited by StephanTual on
  • alexalex Member Posts: 1
    My address is: 58039dfb93f710b189a93a89c7af6bac71fea1c0
    Please send me some wei! and How do I know if I have coins?
  • Wil611Wil611 Member Posts: 77 ✭✭
  • Wil611Wil611 Member Posts: 77 ✭✭
    I finally have the latest client running it is dramatically different from earlier versions.

    Can someone send me some wei to cba18efca90a93ea3fc5530e1f533ceb7b61b282
  • MilanMilan San Diego, CAMember Posts: 46
Sign In or Register to comment.