Geth/v0.9.35 doesn't catch up with blockchain!?

mikmik Member Posts: 57 ✭✭

I unfortunately corrupted my blockchain after I ran out of diskspace, and had to erase it :(.
I ran 'geth removedb' and started geth to download the bc again. It worked quite ok for the first few hours, but now its almost stuck. (btw I also moved .ethereum to another disk and set a link)
I'm currently around block #619901. The downloader only imports 256 blocks every 10min or so! So you can calculate that I will nearly never catch up the current block while I live ;)!
I restarted geth but it didn't change. It is also connected to only 3 peers after hours.

So whats wrong? Can I fix this somehow?

Tx guys for any help!

PS: If this helps: when it is up, my node is "The Dominion" on


  • mikmik Member Posts: 57 ✭✭
  • mikmik Member Posts: 57 ✭✭
    edited July 2015
    Currently I'm at block #626045 at 15:52
    This means from 11:45 where I was at #620157 I catched up only 5.888 blocks
    That means, to catch up the other 141.347 blocks left (to date), I have to wait another 96h=4 days!!!
    Where will the blockchain then be?

    Is there really no solution on Ubuntu 14.04???

    Giving up in the meantime :(:s
  • o0ragman0oo0ragman0o Member, Moderator Posts: 1,291 mod
    @Mik. Yep hearing you but perhaps it not as bad as you're thinking.... 256 block is about 40 to 50 minutes worth so as long as you're importing within 20 minutes or so, you're still catching up.

    In 0.9.35, you can type admin.chainSyncStatus that will give you an estimated time to synch.

    However, even when my client think's it's synched, it's still 10 or more blocks behind. Then it'll stall and soon enough it's trying to import a 100 or so blocks.

    What's more, it doesn't make sense to keep mining when the client knows it's not synched. I don't know if that issue has been raised.
  • mikmik Member Posts: 57 ✭✭
    Thanks for the tip! It's even worse than calculated:
    > admin.chainSyncStatus
    blocksAvailable: 134739,
    blocksWaitingForImport: 1024,
    estimate: '133h27m30.197779776s',
    importing: 58
    I also get following error:
    3896 downloader.go:237] Synchronisation failed: no peers to keep download active
    Can I define manually, to which peers I want to connect?
  • o0ragman0oo0ragman0o Member, Moderator Posts: 1,291 mod
    I believe you can add a static peer by their enode address: admin.addPeer(
    you can try mine:

    But it never properly synchs. It thinks it does but it's always 10 to 100 or more blocks behind and so only mines 'stale blocks'. :(
  • mikmik Member Posts: 57 ✭✭
    Thanks a lot for help! I'll try your node and see what happenes :)
  • mikmik Member Posts: 57 ✭✭
    Maybe your node is down @14:07CET but I get following error (same as a try in the morning):
    (anonymous): Line 1:15 Unexpected token ILLEGAL (and 1 more errors)
    Also tried the command in this form:
    > admin.addPeer() 4fb897afaaa24b5051043ebeb5ff723d5795be653fe70a89608bb64c5831b2bbb4ead7a395e5e533a8f08840ae464fd7f2314f159b7596224f4b4b09c9c819a8
    but got the same error. Following syntax:
    > admin.addPeer("4fb897afaaa24b5051043ebeb5ff723d5795be653fe70a89608bb64c5831b2bbb4ead7a395e5e533a8f08840ae464fd7f2314f159b7596224f4b4b09c9c819a8")
    Invalid JSON RPC response
    at InvalidResponse (:-53186:-146)
    at send (:-109040:-146)
    at addPeer (:-97784:-146)
    at :1:1
    Can I check if I'm connected to a certain node? Is there a doc of the admin commands? I only could find a doc of the commandline options.

    The netstats shows that I'm currently connected to 9 peers, but still the download just dosn't make any significant progess???
  • Dude_xDude_x Member Posts: 40
    Sometime it helps when you do a update to the latest version.
  • obscurenobscuren Member Posts: 38 ✭✭
    Develop branch will help you with this issue. Either update manually or wait for the release on monday :-)
  • o0ragman0oo0ragman0o Member, Moderator Posts: 1,291 mod
    @mik. hmm not sure of the actual syntax. try...
    'enode://4fb897afaaa24b5051043ebeb5ff723d5795be653fe70a89608bb64c5831b2bbb[email protected][::]:30303'
  • mikmik Member Posts: 57 ✭✭
    @Dude_x & @obscuren:
    Thanks guys, but I thought I'm always on the latest version!? Currently I've installed:
    Version: 0.9.35
    Protocol Versions: [61 60]
    Network Id: 0
    Go Version: go1.4.2
    OS: linux
    I manually run the Ubuntu 14.04 update manager at least twice a day to always have the latest geth installed.
    My trusted apt sources are:
    deb trusty main
    deb trusty main
    deb trusty main
    Or is there a better way to be on the latest release? I'm not so savvy yet :(
    Unfortunately nothing changes. As soon as the bc reaches blocks around 600000, the speed of the downloader breaks down to the above said :(
    Current chainSyncStatus:
    blocksAvailable: 178008,
    blocksWaitingForImport: 1024,
    estimate: '121h59m37.294552712s',
    importing: 544
  • motoaddictmotoaddict Fort Myers, FloridaMember Posts: 52
    obscuren said:

    Develop branch will help you with this issue. Either update manually or wait for the release on monday :-)

    ... installed 0.9.36. Doesn't look much better. ;)
  • bitcoinaholicbitcoinaholic Member Posts: 8
    Something is just not quite right. I have been unable to keep up with the blockchain for about two weeks now. Very frustrating.

    Yes, I'm running the latest geth.

    The problem is when I turn my miners on and point them to my local geth node, I invariably fall behind 1 or 2 blocks. The miners then start hashing these stale blocks and cause geth to fall further behind.
  • bitcoinaholicbitcoinaholic Member Posts: 8
    Actually...6 days and counting not being to keep up with blockchain.
  • o0ragman0oo0ragman0o Member, Moderator Posts: 1,291 mod
    Only 1 to 2 blocks? lucky you. If I get anywhere near best block, it just seems to stop importing until I'm 100 or more behind again. I've just built 0.9.36 and currently it's importing 29 and waiting for another 123....which will be more by the time they're imported.

    System Monitor is usually showing Load at over 4 (of 4 cores) on my Quad Core yet CPU usage isn't nearly that high and there's no swapping going on, so geth IO is the only thing that's lagging the whole show.

    IO on 0.9.36 is supposed to be much better as it was the HDD trashing that seems to have kept the block imports and validations so slow. Have to look into 'lazy validation'.

    But then, when I am supposedly sync'ed, the IO drops off, but is simply doesn't seem to pick up new blocks as they come in. When it does, it's like a chain for 50 or more blocks.
  • the_generatorthe_generator Member Posts: 4
    Ok, it seems I am not the only one... At the moment, I am running 5 geth-nodes (0.9.36 dev-snapshot) on 5 PCs and they all have the same problem ...
  • StephanTualStephanTual London, EnglandMember, Moderator Posts: 1,282 mod
    @the_generator and @o0ragman0o - if one of you could please a) git pull b) raise the verbosity on your client and post the log and a link to a paste bin as a new issue on, thank you.
  • mikmik Member Posts: 57 ✭✭
    Thanks Stephan,
    as I commented in another thread, I was finally able to solve the problem with the then newest release (0.9.39) and a new blockchain :) Somewhere I read, the problem could have been caused due to the pre-0.9.36 'stats'-dir.

    I also started to save the latest state of .ethereum to another disk nearly every time after I close geth - just in case the bc gets corrupted again ;)

    BTW: Thanks to you and the whole dev team for the great work!!!
  • motoaddictmotoaddict Fort Myers, FloridaMember Posts: 52
    Seeing some blockchain lag on 0.9.39. Number of peers never gets above 3. Anything I should/could be doing to improve this? I was doing well a couple of days ago on 0.9.36.
  • the_generatorthe_generator Member Posts: 4
    Running the latest version of geth, my nodes are all sync now... The issue of not catching up was probably due to high usage of the network/spamming transactions ...?
  • saxer81saxer81 Member Posts: 1
    Hi all, I'm using frontier 1.0 geth client. After starting the client the blockchain doesn't synchronize. If I give admin.chainSyncStatus on the console the result is always
    blocksAvailable: 0,
    blocksWaitingForImport: 0,
    estimate: '0',
    importing: 0

    I am a new bye on ethereum, do I have to add peers manually?
Sign In or Register to comment.