Stuck at "Starting Server"

JMAHHJMAHH Member Posts: 5
edited July 2015 in Geth - Go Implementation
Hi, I'm on Windows 7 and have successfully built the genesis block, according to the console.

However it gets stuck at Starting Server:
C:\Users\Mr MASHEK>geth --genesis genesis_block.json
I0731 11:16:51.629113     620 backend.go:289] Protocol Versions: [61 60], Networ
k Id: 1
I0731 11:16:52.219147     620 genesis.go:88] Genesis block already in chain. Wri
ting canonical number
I0731 11:16:52.220147     620 backend.go:301] Successfully wrote genesis block.
New genesis hash = d4e56740f876aef8c010b86a40d5f56745a118d0906a34e69aec8c0db1cb8
fa3
I0731 11:16:52.220147     620 backend.go:318] Blockchain DB Version: 3
I0731 11:16:52.221147     620 chain_manager.go:251] Last block (#0) d4e56740f876
aef8c010b86a40d5f56745a118d0906a34e69aec8c0db1cb8fa3 TD=17179869184
I0731 11:16:52.227147     620 cmd.go:122] Starting Geth/v1.0.0/windows/go1.4.2
I0731 11:16:52.227147     620 server.go:311] Starting Server
(I've run removedb multiple times)
And if I try something like "geth console" it just gets me the same.

Version
Geth
Version: 1.0.0
Protocol Versions: [61 60]
Network Id: 1
Go Version: go1.4.2
OS: windows
GOPATH=
GOROOT=C:\Go\

Is this a network issue? It just doesn't seem to connect.

Edit: btw I did exactly the same on Mac and it worked. On Windows I don't even get the user agreement when I load the genesis block.

Comments

  • Marvell9Marvell9 Member Posts: 593 ✭✭✭
    edited August 2015
    yeah I have the same issue I opened a new issue
  • JMAHHJMAHH Member Posts: 5
    In the meantime I upgraded to Windows 10 and now the server is actually starting, but I've hit the next snag! It fails to retrieve nodes. Discovery bootstrap and lookup fail. Goes into a loop. Any help massively appreciated.
    I0804 13:20:04.033825    6732 backend.go:555] Server started
    I0804 13:20:04.033825    6732 server.go:431] new task: discovery bootstrap
    I0804 13:20:04.033825    6732 server.go:548] Listening on [::]:30303
    I0804 13:20:04.036829    6732 ipc_windows.go:696] IPC service started (\\.\pipe\geth.ipc)
    I0804 13:20:04.038837    6732 database.go:185] failed to retrieve node 487611428e6c99a11a9795a6abe7b529e81315ca6aad66e2a2fc76e3adf263faba0d35466c2f8f68d561dbefa8878d4df5f1f2ddb1fbeab7f42ffb8cd328bd4a: leveldb: not found
    I0804 13:20:04.043834    6732 table.go:376] Bonding 487611428e6c99a1: known=false, fails=0
    I0804 13:20:04.038837    6732 database.go:185] failed to retrieve node a979fb575495b8d6db44f750317d0f4622bf4c2aa3365d6af7c284339968eef29b69ad0dce72a4d8db5ebb4968de0e3bec910127f134779fbcb0cb6d3331163c: leveldb: not found
    I0804 13:20:04.047842    6732 table.go:376] Bonding a979fb575495b8d6: known=false, fails=0
    I0804 13:20:04.047341    6732 udp.go:413] >>> 5.1.83.226:30303 discover.ping
    I0804 13:20:04.038837    6732 database.go:185] failed to retrieve node de471bccee3d042261d52e9bff31458daecc406142b401d4cd848f677479f73104b9fdeb090af9583d3391b7f10cb2ba9e26865dd5fca4fcdc0fb1e3b723c786: leveldb: not found
    I0804 13:20:04.053347    6732 table.go:376] Bonding de471bccee3d0422: known=false, fails=0
    I0804 13:20:04.050346    6732 udp.go:413] >>> 52.16.188.185:30303 discover.ping
    I0804 13:20:04.055351    6732 udp.go:413] >>> 54.94.239.50:30303 discover.ping
    I0804 13:20:04.404093    6732 udp.go:468] <<< 5.1.83.226:30303 *discover.pong: expired
    I0804 13:20:04.555741    6732 server.go:465] <-taskdone: discovery bootstrap
    I0804 13:20:04.555741    6732 server.go:431] new task: discovery lookup
    I0804 13:20:04.555741    6732 database.go:185] failed to retrieve node a979fb575495b8d6db44f750317d0f4622bf4c2aa3365d6af7c284339968eef29b69ad0dce72a4d8db5ebb4968de0e3bec910127f134779fbcb0cb6d3331163c: leveldb: not found
    I0804 13:20:04.557727    6732 table.go:376] Bonding a979fb575495b8d6: known=false, fails=0
    I0804 13:20:04.555741    6732 database.go:185] failed to retrieve node 487611428e6c99a11a9795a6abe7b529e81315ca6aad66e2a2fc76e3adf263faba0d35466c2f8f68d561dbefa8878d4df5f1f2ddb1fbeab7f42ffb8cd328bd4a: leveldb: not found
    I0804 13:20:04.560726    6732 table.go:376] Bonding 487611428e6c99a1: known=false, fails=0
    I0804 13:20:04.559728    6732 udp.go:413] >>> 52.16.188.185:30303 discover.ping
    I0804 13:20:04.555741    6732 database.go:185] failed to retrieve node de471bccee3d042261d52e9bff31458daecc406142b401d4cd848f677479f73104b9fdeb090af9583d3391b7f10cb2ba9e26865dd5fca4fcdc0fb1e3b723c786: leveldb: not found
    I0804 13:20:04.565731    6732 table.go:376] Bonding de471bccee3d0422: known=false, fails=0
    I0804 13:20:04.563731    6732 udp.go:413] >>> 5.1.83.226:30303 discover.ping
    I0804 13:20:04.567731    6732 udp.go:413] >>> 54.94.239.50:30303 discover.ping
    I0804 13:20:04.681812    6732 udp.go:468] <<< 54.94.239.50:30303 *discover.pong: expired
    I0804 13:20:04.681812    6732 udp.go:468] <<< 54.94.239.50:30303 *discover.ping: expired
    I0804 13:20:04.859938    6732 udp.go:468] <<< 5.1.83.226:30303 *discover.pong: expired
    I0804 13:20:05.068106    6732 server.go:465] <-taskdone: discovery lookup
  • Marvell9Marvell9 Member Posts: 593 ✭✭✭
    you have to open the corret ports on your firewall and router as well

    I forget the port 30300 or something ask around
  • StephanTualStephanTual London, EnglandMember, Moderator Posts: 1,282 mod
    30303 is the port that needs mapping if UPnP doesn't work with your router.
  • JMAHHJMAHH Member Posts: 5
    Here's the thing, my router does support UPnP. If I do it with my mac, and geth tells me TCP and UDP have been mapped on 30303, I can actually see them in the UPnP list in the router config.

    If I do it with windows, geth tells me both have been mapped but they do not show up in the router list.
  • Marvell9Marvell9 Member Posts: 593 ✭✭✭
    Thanks Stephan i was too lazy to look up the port.

    JMAHH one good test i have found to resolve network issues is turn off the firewall on the router and on windows completely to see if that is where your issue is is , only do this for the short duration of your test of course and turn it back on once you have determined if the issue is with your network i.e if it starts working after both are off.

    then you can work backwards to isolate where the actual issue is.

    the UPnP thing could be overblown basically its the multicast setting. Check if your router has a multicast setting and if it does turn it on for all IPS , if it does not have multicast (which i cant imagine it wont for a modern router) then thats not your problem.
  • Marvell9Marvell9 Member Posts: 593 ✭✭✭
    also somebody said this specifically for windows 10

    Note: On Windows 10 you may need to activate the Windows Time service from the "Start Menu > Services" and set setup to automatic. Some users report that this service is disabled by default in Windows 10.

    you should try that first
  • JMAHHJMAHH Member Posts: 5
    edited August 2015
    Actually it works now. Maybe it was a simple router reset to apply changes. The firewalls were not the issue.

    Off-topic question: if I run ethminer directly without doing "geth -rpc" first, is that ok? It seems to be working normally.
    Post edited by JMAHH on
Sign In or Register to comment.