What Causes Rejected Shares?

techtottechtot Member Posts: 339 ✭✭✭
I started up a miner Friday night and sometime Saturday shares started getting rejected. I restarted the "ethminer" which didn't fix it, but when I restarted the proxy and the miner , shares were accepted again. Is this a proxy problem ? It's frustrating, because ethminer runs at full wattage even though all shares are rejected.

Comments

  • retherrether Member Posts: 258 ✭✭
    The most common reason would be overclocking the card too far or a corrupted DAG file.
  • AbcedarianAbcedarian Member Posts: 76
    edited August 2016
    When I look at a calculator, it seems I am getting about as much eth as I should expect. 146mhs Day 0.905135 $10.00
    but I have a lot of invalid shares.



    from MHP
    Round Shares Submitted shares since last found block (ie. round shares)
    Est. Shares 4,681,152 (done: 57.38%)
    Your Valid 8,007.6900
    20.9591 (1 level stale 0.11%)
    Your Invalid 10,735.5726 (57.21%)

    These are the GPU's and their clocks
    miner_hashes:16.61 29.67 30.96 30.90
    models:01: Advanced Micro Devices, Inc. [AMD/ATI] Tahiti XT [Radeon HD 7970/R9 280X]
    03: Advanced Micro Devices, Inc. [AMD/ATI] Hawaii PRO [Radeon R9 290/R9 390] (rev 80)
    04: Advanced Micro Devices, Inc. [AMD/ATI] Hawaii PRO [Radeon R9 290/R9 390] (rev 80)
    06: Advanced Micro Devices, Inc. [AMD/ATI] Hawaii PRO [Radeon R9 290/R9 390] (rev 80)
    bioses:113-C3865000-O77 MS-V30823-F5 MS-V30823-F5 MS-V30823-F5
    default_core:1020 1040 1040 1040
    default_mem:1500 1500 1500 1500
    core:1000 1150 1175 1175
    mem:1500 1500 1600 1600
    (There is another 2 GPU rig as well)

    Do you think I should change the clocks in some way? I worked at it for a few days to get the hash rate as high as I could and then really haven't messed with things.

    DAG file is regenerated with each start right?

    TIA


  • retherrether Member Posts: 258 ✭✭

    When I look at a calculator, it seems I am getting about as much eth as I should expect. 146mhs Day 0.905135 $10.00
    but I have a lot of invalid shares.



    from MHP
    Round Shares Submitted shares since last found block (ie. round shares)
    Est. Shares 4,681,152 (done: 57.38%)
    Your Valid 8,007.6900
    20.9591 (1 level stale 0.11%)
    Your Invalid 10,735.5726 (57.21%)

    These are the GPU's and their clocks
    miner_hashes:16.61 29.67 30.96 30.90
    models:01: Advanced Micro Devices, Inc. [AMD/ATI] Tahiti XT [Radeon HD 7970/R9 280X]
    03: Advanced Micro Devices, Inc. [AMD/ATI] Hawaii PRO [Radeon R9 290/R9 390] (rev 80)
    04: Advanced Micro Devices, Inc. [AMD/ATI] Hawaii PRO [Radeon R9 290/R9 390] (rev 80)
    06: Advanced Micro Devices, Inc. [AMD/ATI] Hawaii PRO [Radeon R9 290/R9 390] (rev 80)
    bioses:113-C3865000-O77 MS-V30823-F5 MS-V30823-F5 MS-V30823-F5
    default_core:1020 1040 1040 1040
    default_mem:1500 1500 1500 1500
    core:1000 1150 1175 1175
    mem:1500 1500 1600 1600
    (There is another 2 GPU rig as well)

    Do you think I should change the clocks in some way? I worked at it for a few days to get the hash rate as high as I could and then really haven't messed with things.

    DAG file is regenerated with each start right?

    TIA


    What miner are you using?

    When I use MPH I have to use the right port and esm setting with claymore or else this will happen.
  • techtottechtot Member Posts: 339 ✭✭✭
    I use Genoil Miner and it does not create a disk DAG file . It starts mining right away. I also didn't overclock anything. I have never really had the problem with Coinotron, but only Dwarfpool. But my more complex setups is going to Dwarfpool, so I guess it could be GPU config related (voltage for mem/gpu).

    However after restarting the proxy and ethminer, I have had good shares for almost 48 hours now, with the same GPU settings...

  • AbcedarianAbcedarian Member Posts: 76
    edited August 2016
    @rether I am using ethOS so port 20536
  • retherrether Member Posts: 258 ✭✭

    @rether I am using ethOS so port 20536

    Don't know anything about ethOS, sorry, but for me I needed to use port 20535 and "esm 2" on Claymore which I believe is the coinotron proxy implementation. Maybe that helps...
  • retherrether Member Posts: 258 ✭✭
    techtot said:

    I use Genoil Miner and it does not create a disk DAG file . It starts mining right away. I also didn't overclock anything. I have never really had the problem with Coinotron, but only Dwarfpool. But my more complex setups is going to Dwarfpool, so I guess it could be GPU config related (voltage for mem/gpu).

    However after restarting the proxy and ethminer, I have had good shares for almost 48 hours now, with the same GPU settings...

    Could have been an issue with the proxy then, probably just a one-time thing if it never reoccurs. I think I recall dwarf using a custom stratum implementation so it's tough to say. Otherwise you can just use the builtin stratum function of Genoil's miner with no need for the proxy software. I don't think dwarf works that way though, but I quit mining there long ago so I'm not sure.
  • techtottechtot Member Posts: 339 ✭✭✭
    @rether, whats your favorite pool? Just curious. I may try another one
  • retherrether Member Posts: 258 ✭✭
    techtot said:

    @rether, whats your favorite pool? Just curious. I may try another one

    I like Mining pool hub and ethermine.
Sign In or Register to comment.