rx480 patched Driver working in win10 without option 7

boysieboysie Member Posts: 591 ✭✭✭
edited August 2016 in Mining
hi all,

just thought I would let you know I managed to get the patched ATI driver working in win10 with out the need to disable driving sig eg booting via option 7

Also I did all this remotely ...so no need for safe mode either.

I am using test mode.

i) Press Windows Key + X to open Power User Menu. Select Command Prompt (Admin) from the menu.
ii) Once the Command Prompt open, enter bcdedit.exe -set loadoptions DISABLE_INTEGRITY_CHECKS and press Enter. Then enter bcdedit.exe -set TESTSIGNING ON and press Enter.
iii) Close Command Prompt and restart your PC.

so here goes.

items you need.

1) ati patched file. win-raid.com/t892f16-AMD-and-Nvidia-GOP-update-No-requests-DIY-19.html#msg30028
2) windows 7 ISO, you can source this yourself
3) a windows 10 system with hyper-v enabled or an already built win7 system or some other way to build a windows 7 system, no need to activate it
4) the sig patching tool ngohq.com/?page=dseo


Build a win 7 system...either use hyper-v locally or get a system with win7 already installed... or any other way..go to your grans and use hers :)
copy the patch file to the desktop of the win7 system
run the sig tool
turn on test mode and reboot
run the tool again
select to sig the sys file and provide the path to the sys file on your desk top
after its complete start > Run > MMC
Add certificate
select Local machine
in root cert auth is a cert called NGO
Right click it and export
Any option I think will work but I used the bottom one and ticket the additional box.
save to desktop as NGO.p7b
now copy the sys file and the cert to your windows 10 system
On windows 10 system
open device manager and disable all GPUs (Right click disable)
copy the patched and new sig file to system32/drivers and overwrite the existing file
right click NGO.p7b and select install
select place this cert in the following store and click browse
select Trusted root cert auth
click OK
click next
Finish
Re-enable your GPUs in device manager
Confirm they load with out issue
if not you did some thing wrong
you can now flash and reboot without the need for option 7 any more.


Enjoy

Boysie

Comments

  • muzzy124muzzy124 Member Posts: 78
    edited August 2016
    My way, at least with 5GPU system:
    1. Enable IGPU (or nividia) as first video card to be initialised by motherboard. Connect monitor to it. Boot, install amd drivers, check that all cards are ok in device manager.
    2. Enable test-signing mode.
    3. Flash patched amd bios to cards, copy patched amd file in safe mode, sign it with dseo in normal mode. The cards will be disabled in device manager.
    4. Reboot. Check if amd cards are enabled in device manager
    5. Disconnect monitor from IGPU (or nvidia), connect it to AMD.
    6. Reboot. Enjoy.
    Haven't try it on 6GPU rig yet. Maybe tomorrow.
  • muzzy124muzzy124 Member Posts: 78
    The feature is that win10 doesn't check if drivers are properly signed on secondary video adapters.
  • HelioxHeliox Member, Moderator Posts: 634 mod
    edited August 2016
    MM can do it easier.

    Boot Windows 10
    Install driver
    go to device manager and disable your gpu (right click -> Disable)
    reboot to safe mode, replace atikmdag.sys
    sign it with that signing tool (Did this in safe mode but i'm sure you can do this after you reboot (next step))
    reboot (while your GPU is still disabled)
    run admin cmd console and run "bcdedit.exe -set TESTSIGNING ON" (not 100% sure if i did this in safe mode yes or no, don't think so..)
    reboot go to device manager and enable your gpu again

    yey B)
  • TruthchanterTruthchanter Member Posts: 549 ✭✭✭
    Heliox said:

    MM can do it easier.

    Boot Windows 10
    Install driver
    go to device manager and disable your gpu (right click -> Disable)
    reboot to safe mode, replace atikmdag.sys
    sign it with that signing tool (Did this in safe mode but i'm sure you can do this after you reboot (next step))
    reboot (while your GPU is still disabled)
    run admin cmd console and run "bcdedit.exe -set TESTSIGNING ON" (not 100% sure if i did this in safe mode yes or no, don't think so..)
    reboot go to device manager and enable your gpu again

    yey B)

    This looks less complicated and quicker than OP, am I missing anything? MM means My Method I'm assuming. "that signing tool" is this 4) the sig patching tool ngohq.com/?page=dseo ?

    And at what point in this quick process do I flash the bios? I want to make sure I completely understand
  • HelioxHeliox Member, Moderator Posts: 634 mod


    This looks less complicated and quicker than OP, am I missing anything? MM means My Method I'm assuming. "that signing tool" is this 4) the sig patching tool ngohq.com/?page=dseo ?

    And at what point in this quick process do I flash the bios? I want to make sure I completely understand

    Signing tool is indeed the one from ngohq.

    MM means mmmm.. :tongue:

    You can flash your bios after you've done these steps "over and over again :tongue: "


    greetings
  • boysieboysie Member Posts: 591 ✭✭✭
    so the signing tool works in win10 ...thought it didn't that's why I went that route of win7 sign and export cert etc.
  • cscheatcscheat Member Posts: 147 ✭✭
    Heliox said:

    MM can do it easier.

    Boot Windows 10
    Install driver
    go to device manager and disable your gpu (right click -> Disable)
    reboot to safe mode, replace atikmdag.sys
    sign it with that signing tool (Did this in safe mode but i'm sure you can do this after you reboot (next step))
    reboot (while your GPU is still disabled)
    run admin cmd console and run "bcdedit.exe -set TESTSIGNING ON" (not 100% sure if i did this in safe mode yes or no, don't think so..)
    reboot go to device manager and enable your gpu again

    yey B)

    Hi Heliox, thank you for all the contributions.

    Quick question. Win10 here.

    I want to ask is it a MUST to patch amd + reboot with option 7 before flashing the modded bios?

    I got 1 dead GPU here. no fan no nothing after flashing
  • YogiYogi Member Posts: 147 ✭✭
  • armymanarmyman Member Posts: 23
    Guys I am trying to set up the following rig:

    Asrock H81 pro btc
    16 gb ram DDR3
    6 x XFX RX480 8gb
    6 x PCI 1x 16
    SSD external memory
    Intel Pentium G3260
    1200 w PSU
    WIN 10 64 bit

    I would like to install the latest version of Claymore's dual miner on it, the problem is that the PC can not even run the 6 GPU's all the same time apparently, without anything installed on it yet, but Windows (I am helping which is setting it up and we are about 2000 miles far from each other, so this doesn't help).

    Windows starts normally if only 3 GPUs are connected, but a black screen will come off if we try to connect all the 6 GPU's.

    Any idea?

    Also which drivers would you recommend for the XFX RX480 8gb? Is the latest crimson driver ok?
    Cause I would like to mod the GPU's bios later on (after running them on stock set up for few days).

    Any help would be deeply appreciated, thank you!
  • frantisekzfrantisekz Member Posts: 7
    I don't know about others but look at OP: http://www.overclock.net/t/1604567/polaris-bios-mod-rx480

    I've flashed modded BIOS few days ago, rebooted and everything is fine. No driver patching. (Win10/RX480/16.9.1)
  • muzzy124muzzy124 Member Posts: 78
    16.9.1 doesn't check bios signatures so option "7" is not needed now
  • frantisekzfrantisekz Member Posts: 7
    muzzy124 said:

    16.9.1 doesn't check bios signatures so option "7" is not needed now

    I might be missing something but why is needed patched driver at all then? Thanks
  • boysieboysie Member Posts: 591 ✭✭✭
    this is old just use 16.9.1 + and no need any more
  • batakbatak Member Posts: 2
    boysie said:

    this is old just use 16.9.1 + and no need any more

    Hello Boysie,

    i am complete newby, so i would apricciate any help- I have 6 gpu rig, saphire nitro + oc 8 gb, but having big troubles making it work.
    Until now i tried win 7, was able to start mining with 4 gpu-s, using ethimner on dwarf pool. Hashrate 88 - 100 Mhs. Found out that win 7 suports up to 4 gpu, so tried with win 10 , but than u had this: one card minning stable, tried to start 6 gpu , ethminer starts, comes to max 96% and than driver crashes. Tried qtminer, same thing, creating Dag file, cpu goes 100% and again, driver crashes.
    Tried to install different versions Crimson, but always same thing.
    If there is known solution, please share it with me? :)
    Rgds
  • yodiyodi Member Posts: 265 ✭✭
    edited December 2016
    batak said:

    boysie said:

    this is old just use 16.9.1 + and no need any more

    Hello Boysie,

    i am complete newby, so i would apricciate any help- I have 6 gpu rig, saphire nitro + oc 8 gb, but having big troubles making it work.
    Until now i tried win 7, was able to start mining with 4 gpu-s, using ethimner on dwarf pool. Hashrate 88 - 100 Mhs. Found out that win 7 suports up to 4 gpu, so tried with win 10 , but than u had this: one card minning stable, tried to start 6 gpu , ethminer starts, comes to max 96% and than driver crashes. Tried qtminer, same thing, creating Dag file, cpu goes 100% and again, driver crashes.
    Tried to install different versions Crimson, but always same thing.
    If there is known solution, please share it with me? :)
    Rgds
    to get 6 x gpu working on win7 you need this mod.
    https://bitcointalk.org/index.php?topic=712228.0

    if i remember , when you update or re-install driver you probably had to execute the mod again

    win10 sucks for me , gpu lost every 5~20 minutes
    i kept win7 and auto reboot it every 12h or 24h with automated login and claymore .bat launch.
    running good like this
  • batakbatak Member Posts: 2
    yodi said:

    batak said:

    boysie said:

    this is old just use 16.9.1 + and no need any more

    Hello Boysie,

    i am complete newby, so i would apricciate any help- I have 6 gpu rig, saphire nitro + oc 8 gb, but having big troubles making it work.
    Until now i tried win 7, was able to start mining with 4 gpu-s, using ethimner on dwarf pool. Hashrate 88 - 100 Mhs. Found out that win 7 suports up to 4 gpu, so tried with win 10 , but than u had this: one card minning stable, tried to start 6 gpu , ethminer starts, comes to max 96% and than driver crashes. Tried qtminer, same thing, creating Dag file, cpu goes 100% and again, driver crashes.
    Tried to install different versions Crimson, but always same thing.
    If there is known solution, please share it with me? :)
    Rgds
    to get 6 x gpu working on win7 you need this mod.
    https://bitcointalk.org/index.php?topic=712228.0

    if i remember , when you update or re-install driver you probably had to execute the mod again

    win10 sucks for me , gpu lost every 5~20 minutes
    i kept win7 and auto reboot it every 12h or 24h with automated login and claymore .bat launch.
    running good like this
    i have problem with win 10, even one gpu makes driver crash every few minutes. I tried every possible driver i could find, result is same :/ so, u sugest to go win 7, with that mod?
  • yodiyodi Member Posts: 265 ✭✭
    edited January 2017
    batak said:

    yodi said:

    batak said:

    boysie said:

    this is old just use 16.9.1 + and no need any more

    Hello Boysie,

    i am complete newby, so i would apricciate any help- I have 6 gpu rig, saphire nitro + oc 8 gb, but having big troubles making it work.
    Until now i tried win 7, was able to start mining with 4 gpu-s, using ethimner on dwarf pool. Hashrate 88 - 100 Mhs. Found out that win 7 suports up to 4 gpu, so tried with win 10 , but than u had this: one card minning stable, tried to start 6 gpu , ethminer starts, comes to max 96% and than driver crashes. Tried qtminer, same thing, creating Dag file, cpu goes 100% and again, driver crashes.
    Tried to install different versions Crimson, but always same thing.
    If there is known solution, please share it with me? :)
    Rgds
    to get 6 x gpu working on win7 you need this mod.
    https://bitcointalk.org/index.php?topic=712228.0

    if i remember , when you update or re-install driver you probably had to execute the mod again

    win10 sucks for me , gpu lost every 5~20 minutes
    i kept win7 and auto reboot it every 12h or 24h with automated login and claymore .bat launch.
    running good like this
    i have problem with win 10, even one gpu makes driver crash every few minutes. I tried every possible driver i could find, result is same :/ so, u sugest to go win 7, with that mod?
    i didn't try yet this bios mod , i m on jukebox v4 (with sapphire nitro+ 8go). running about 24 hours , sometimes black screen or gpu lost but rarely instead of win10

    the best is ... to try, install all driver for motherboard and else , get driver 16.11.5 if you switch miners (zec,xmr,...) because 16.9.2 is stable but get fans bug with Clay.cryptonote 9.6 (xmr).
    and when running good , get restore point ...

    dont forget install 6xGPU mod after driver install if you have more of 4 gpu. you'll need to re-install it after every driver change (update/install)
  • momomomo Member Posts: 15
    I'm running 6 x Sapphire nitro RX480 and one GPU is failing.
    System is with two PSUs ThermalTake 730W. GPU that is failing is on PSU that is powering motherboard also.

    This can be due to PSU not being able to push 3 GPUs?

    or

    Can this be resolved by TDR setting in registry?
Sign In or Register to comment.