[UPDATE]RX480 (Reference) Custom rom: 31+Mh

1568101117

Comments

  • Dr_House86Dr_House86 Member Posts: 566 ✭✭✭
    Could someone please measure the wattage from the wall?

    And it would be nice If someone would make a short turtorial on how to flash the gpu bios ;)
  • HelioxHeliox Member, Moderator Posts: 634 mod
    boysie said:

    why do this ? it totally fu*ks wattman




    :(

    Forces your gpu to remain at DPM3 in stead of jumping around. ;)

  • CalivetCalivet Member Posts: 194 ✭✭
    Running Heliox low energy rom. 645w from the power meter. That's 4x Rx480. Two 120 mm fans.
  • un4givenun4given Member Posts: 172 ✭✭
    Calivet said:

    Running Heliox low energy rom. 645w from the power meter. That's 4x Rx480. Two 120 mm fans.

    Dual Mining? If yes, what dcri value? What other rig components? What PSU?
  • Hidde_HooglandHidde_Hoogland Member Posts: 12
    ETGoHome said:

    Here is a screenshot of my energy efficient tweaked Heliox bios. If Heliox, is ok with me posting a modified version of his bios. Then I will. Thanks Heliox.

    This consumes less power, generates less heat, and almost same as high hashrate.

    Show me the Settings please!
  • FlexinFlexin FranceMember Posts: 45

    Could someone please measure the wattage from the wall?

    And it would be nice If someone would make a short turtorial on how to flash the gpu bios ;)

    Same questions like @Dr_House86, i really want to try your LOW energy Rom, but i don't know how to do it since i'm not really good in computers :blush:

    Thanks for your work.
  • ShawnYShawnY Member Posts: 58
    Tried my hands to flash 1 card at a time, but unable to get drivers to be recognized in Test mode.
    Rolled back to stock bios in the meantime.
    Not easy to get custom bios to work in Win10.. :(:(:(
  • ShawnYShawnY Member Posts: 58
    herpi said:

    Heliox said:

    @boysie

    Did you really reinstall drivers? :)


    What i do is this.

    1: (while everything is at stock, so stock rom, stock driver) i execute this command first (as admin)

    bcdedit /set nointegritychecks on


    2: I reboot to safe mode(Hold Shift while clicking reboot) and i replace that atikmdag.sys file.

    3: I reboot back into windows with that replaced atikmdag file. Windows should load perfectly, same for your drivers.

    4: I flash my rom (command line atiflash, also as admin)

    5: I reboot with signature checks disabled (also holding left shift while hitting the reboot button), you can do this in the next screen after you clicked reboot while holding left shift. You'll get a menu and you just do this. (same applies for Safe mode)
    Troubleshoot > Advanced options > Startup Settings and click Restart


    6: Everything should look perfectly fine when rebooted (i do not get the "test mode" message in the lower right corner. It just works :tongue:


    greetings!

    Hello,

    i tried your steps at Windows 10 x64. I got stuck at Step 3. The driver wont work.





    Yup, im stuck with drivers unable to load even after replacing modded driver
  • sevenzsevenz Member Posts: 8
    Second card gets code 43 error too :neutral:
  • ShawnYShawnY Member Posts: 58
    Well, as much as i love to be in the 30+MH rx480 club, I can't. Back to good 'ol stock bios for me :'(:'(
  • boysieboysie Member Posts: 591 ✭✭✭
    Heliox said:

    boysie said:

    why do this ? it totally fu*ks wattman




    :(

    Forces your gpu to remain at DPM3 in stead of jumping around. ;)

    I'm not sure I agree there...based on behaviour i've seen...and it also means in wattman you cant change it...at least in the version I'm using
  • charles2kcharles2k Member Posts: 22
    Heliox said:

    Here, it's the same, 1100 core, 2125 mem lowered mem voltage, tdp.

    Low Energy Rom
    Based on 4GB version, my bad :tongue:


    Low Energy Rom OK
    Correct one!

    So for reference RX480 8G card has BIOS only 256kB and for 4GB version has 512kB ??
  • YogiYogi Member Posts: 147 ✭✭
    boysie said:

    Heliox said:

    boysie said:

    why do this ? it totally fu*ks wattman




    :(

    Forces your gpu to remain at DPM3 in stead of jumping around. ;)

    I'm not sure I agree there...based on behaviour i've seen...and it also means in wattman you cant change it...at least in the version I'm using
    Did you try a wattman reset ? I haven't tried the BIOS yet, just wondering if a reset sorts it.
  • CalivetCalivet Member Posts: 194 ✭✭
    solo mining only. PSU is a gold 80 + 1000 w EVGA. Basic setup h97 anniversary mobo. 1150 socket cpu. 8 gb of ram. Two 120 mm cool master fans.
  • CalivetCalivet Member Posts: 194 ✭✭
    @ETGoHome your rom is for a 4gb only, correct?
  • Marvell9Marvell9 Member Posts: 593 ✭✭✭
    Calivet said:

    @ETGoHome your rom is for a 4gb only, correct?

    does it really matter even? it seems that the 4gb cards can be flashed to 8gb since the mem chips are simply disabled

    the bigger question is how much power savings with your bios vs the new Heliox rom thats at 2125 mem vs 2225
  • CalivetCalivet Member Posts: 194 ✭✭
    For everyone else. Here is what I did.

    Brand new system. Clean install of windows 10. Installed amd drivers 16.7.
    1. (possible to use the newest hotfix version but I went with 16.7.1) Download GPU Z. Download atiflash 2.74 (latest version that supports rx 480) unzip it into a folder where it would be easy for you to find. Download the mod driver at the website given by Heliox. Unzip the modded driver file to a folder that would be easy for you to find. Download the modded bios and unzip it to a folder where it would be easy for you to find. Download Claymore dual miner 6.0. Unzip it to a folder where it would be easy for you to find.

    Followed Heliox instructions:
    i) Press Windows Key + X to open Power User Menu. Select Command Prompt (Admin) from the menu.
    ii) Once the Command Prompt open, enter bcdedit.exe -set loadoptions DISABLE_INTEGRITY_CHECKS and press Enter. Then enter bcdedit.exe -set TESTSIGNING ON and press Enter.

    instead of restart my pc and booting it to regular windows, I hold down the "shift" key and restart. It will give you to the advance options. It will get you to the advance start up options. Click restart. Enter the correct number for safe mode.

    Once in safe mode, replace the driver file with the modded file. Once that is done. Hold down the shift key again and select restart. Go to advance start up options. Restart.

    Press 7 to disable sig.(it if works correctly your screen will not be big like you don't have any video drivers installed. If you see big icons and such, hold shift restart again, press 7 option again, til you see a normal windows with normal size icons) Once there you can flash your gpu using atiflash.
    Go to where you unzipped atiflash. Right click on winflash and run as administrator.
    Very simple to do as it gives you a Graphic User Interface. Click on the far left option, which is open or whatever (I can't see the correct option since I have more than three gpu connected). Search for the modded bios rom. Select it. Select the gpu you want to flash. Click on program. It will flash your gpu. (You can flash up to three gpu but I would recommend doing one at a time. ) When it is done flashing you gpu. You will get the message, "your bios was programmed successfully" or something similar to that. It will ask you to restart. Click no. Then close out all programs. Shutdown the rig. Unplug power. Wait a min. Boot back up. Should take you back to reg Windows. Hold down Shift key and restart. Go to advance start up options. Restart. Select option 7. (til you see regular size icons)

    Run claymore miner. Adjust wattman (fan settings to your liking) I put fan settings on manual. min of 4200 and max of 5200. Keeps my gpu around 60's, fans in mid 70's.

    That's what I did. Followed the instructions given by @Heliox @boysie and Got everything to go first round. The only issue I have now is with claymores dual miner 6.0. I woke up this morning and all three of my rigs were hung up. Switched back to 5.3 for two of my r9 390 rigs. Rx 480 rig is still running CDM 6.0.

    Hope this helps everyone else who is having issues.
  • CalivetCalivet Member Posts: 194 ✭✭
    @Marvell9 even if its a 4gb rom, it can be edited into a 8gb rom. Just asking if he uploaded the correct rom.
  • CalivetCalivet Member Posts: 194 ✭✭
    @Yogi with the modded rom, a rest in wattman will not do anything.
  • CalivetCalivet Member Posts: 194 ✭✭
    @charles2k I got that message too. Still I flashed with no issues.
  • SIRacer09SIRacer09 Member Posts: 246 ✭✭
    @Heliox I'm getting close on Win7! My hashrate on the cards are jumping from 23-31mhs using claymore, not stable at all. I was able to change the mem, but which setting did you change for core for the 31mhs setting? Mine are jumping all over the place on 8GB cards.
  • ETGoHomeETGoHome Member Posts: 36
    edited August 2016
    Would also like to post that it works 100% on windows 7 using the latest drivers, it didn't work when i was using 16.7.1 drivers.
    Marvell9 said:

    Calivet said:

    @ETGoHome your rom is for a 4gb only, correct?

    does it really matter even? it seems that the 4gb cards can be flashed to 8gb since the mem chips are simply disabled

    the bigger question is how much power savings with your bios vs the new Heliox rom thats at 2125 mem vs 2225
    My rom is just a tweaked version of Heliox rom, so if it was the 4gb, then mine is the 4gb. But a 4gb bios can be flashed on a 8gb card and visa versa. This only applies to the reference cards though during launch.
  • TruthchanterTruthchanter Member Posts: 549 ✭✭✭
    Calivet said:

    For everyone else. Here is what I did.

    Brand new system. Clean install of windows 10. Installed amd drivers 16.7.
    1. (possible to use the newest hotfix version but I went with 16.7.1) Download GPU Z. Download atiflash 2.74 (latest version that supports rx 480) unzip it into a folder where it would be easy for you to find. Download the mod driver at the website given by Heliox. Unzip the modded driver file to a folder that would be easy for you to find. Download the modded bios and unzip it to a folder where it would be easy for you to find. Download Claymore dual miner 6.0. Unzip it to a folder where it would be easy for you to find.

    Followed Heliox instructions:
    i) Press Windows Key + X to open Power User Menu. Select Command Prompt (Admin) from the menu.
    ii) Once the Command Prompt open, enter bcdedit.exe -set loadoptions DISABLE_INTEGRITY_CHECKS and press Enter. Then enter bcdedit.exe -set TESTSIGNING ON and press Enter.

    instead of restart my pc and booting it to regular windows, I hold down the "shift" key and restart. It will give you to the advance options. It will get you to the advance start up options. Click restart. Enter the correct number for safe mode.

    Once in safe mode, replace the driver file with the modded file. Once that is done. Hold down the shift key again and select restart. Go to advance start up options. Restart.

    Press 7 to disable sig.(it if works correctly your screen will not be big like you don't have any video drivers installed. If you see big icons and such, hold shift restart again, press 7 option again, til you see a normal windows with normal size icons) Once there you can flash your gpu using atiflash.
    Go to where you unzipped atiflash. Right click on winflash and run as administrator.
    Very simple to do as it gives you a Graphic User Interface. Click on the far left option, which is open or whatever (I can't see the correct option since I have more than three gpu connected). Search for the modded bios rom. Select it. Select the gpu you want to flash. Click on program. It will flash your gpu. (You can flash up to three gpu but I would recommend doing one at a time. ) When it is done flashing you gpu. You will get the message, "your bios was programmed successfully" or something similar to that. It will ask you to restart. Click no. Then close out all programs. Shutdown the rig. Unplug power. Wait a min. Boot back up. Should take you back to reg Windows. Hold down Shift key and restart. Go to advance start up options. Restart. Select option 7. (til you see regular size icons)

    Run claymore miner. Adjust wattman (fan settings to your liking) I put fan settings on manual. min of 4200 and max of 5200. Keeps my gpu around 60's, fans in mid 70's.

    That's what I did. Followed the instructions given by @Heliox @boysie and Got everything to go first round. The only issue I have now is with claymores dual miner 6.0. I woke up this morning and all three of my rigs were hung up. Switched back to 5.3 for two of my r9 390 rigs. Rx 480 rig is still running CDM 6.0.

    Hope this helps everyone else who is having issues.

    my 480 rig uses win10 and is in a remote location and i use Google chrome remote desktop to access and monitor it. In the motherboard bios, i have it set to boot when the power is connected so if the power goes out it reboots back up.

    Is there anyway to have it autoboot (if power goes out) into the option 7 disabled sigs so I can use the modded bios? If not, are there any extra steps to get the modded bios working in win7?
  • CalivetCalivet Member Posts: 194 ✭✭
    @Truthchanter , I believe with claymore if you enable the wd 1 and R 1 options with the reboot.bat file, it should reboot. Now to reboot into windows with the driver signatures disable? I haven't come across a way to do that. Is it possible, I really don't know. However with the rx 480, there is no programs to save the settings yet so even with a reboot with signatures disable would prob do no good since you would have to manual set the settings. Now if you enable claymore to set the fans and use the modded bios, it might be possible since you would not have to set the settings for your gpu beside the fan settings.
  • YogiYogi Member Posts: 147 ✭✭
    edited August 2016

    Could someone please measure the wattage from the wall?

    And it would be nice If someone would make a short turtorial on how to flash the gpu bios ;)

    950w @ the wall using slightly improved version of the 31mh rom. 183mh total.
    There is a low power one as well. giving around 174mh. Im guessing around 800w-850 @ the wall.
    That's for a 6 card rig.
    Post edited by Yogi on
  • ETGoHomeETGoHome Member Posts: 36
    edited August 2016
    Ok, after some more tweaking, for those that want the best watt to hash ratio, i think this is my final version. Energy is the most important factor to me, so I had to tweak it and lower it a bit and got a sweet spot.
    This is about 27-28 Mh/s at 0.85v with a GPU-Z of about 65w.

    Here are my wattman settings:




    Rom file is below:
  • nhandonhando Member Posts: 82
    Does this ROM work with any of the RX480 reference card brand or is there a particular brand it won't work with . I recall hearing some folks having issues with PowerColor cards on Bitcointalk?
  • billcryptokidbillcryptokid Member Posts: 80
    I cant seem to get any of the roms to work dualmining with any decent rates except for @boysie rom, and even then i have to edit it within wattman for a 30.3mh/440 @97W and .08ish volts. Not sure why...
  • CalivetCalivet Member Posts: 194 ✭✭
    edited August 2016
    @nhando I have an msi, two sapphires and one xfx with the back plate. For the mis and sapphires they work perfectly. For the xfx you need to type in the correct sub system id (which can be easily done with the polaris bios edit.) This might be the case fore powercolor also. @billcryptokid as you can see most of the roms are doing single solo mining. So I would assume that it is only meant for solo mining. Dual mining would need a little bit more juice and tweaking to get the hash rate you want. @Truthchanter in the reboot.bat file if you put in the command line shutdown /r /o /f /t 00. When you minner gets an issue it will auto shutdown to the advance options screen. There you would have to manually adjust it. I think that being able to permanently disable the sig driver is available in windows 10 pro version only (as I have done some research) (if you have windows 10 pro version, google windows 10 gpedit.msc., also I believe you can permanently disable driver sig in windows 7)
  • nhandonhando Member Posts: 82
    edited August 2016
    @calivet. Yes I'm getting ready to do the XFX right now. Your detail posting of the step by step is what gave me the courage to try. Thanks for that. May I also get the step fpr the xfx bios edit you are referring to?? Thanks so much. Also where can i download the high performance ROM from heliox and boysie?? Which do u recommend for dual mining??

    P.S Also where is the Mod driver file located? Any links?
    Post edited by nhando on
Sign In or Register to comment.