cpp-ethereum install not working

When attempting to install cpp-ethereum on ubuntu 14 LTS, (and subsequently when I try to force it, as below) I get the following error:

[email protected]:/etc/puppet$ sudo apt-get -f install
Reading package lists... Done
Building dependency tree
Reading state information... Done
Correcting dependencies... Done
The following extra packages will be installed:
solc
The following NEW packages will be installed:
solc
0 upgraded, 1 newly installed, 0 to remove and 14 not upgraded.
127 not fully installed or removed.
Need to get 0 B/2,042 kB of archives.
After this operation, 15.3 MB of additional disk space will be used.
Do you want to continue? [Y/n] Y
(Reading database ... 77218 files and directories currently installed.)
Preparing to unpack .../solc_1%3a0.3.6-nightly-2016-08-10-fh-3fc68da-0ubuntu1~trusty_amd64.deb ...
Unpacking solc:amd64 (1:0.3.6-nightly-2016-08-10-fh-3fc68da-0ubuntu1~trusty) ...
dpkg: error processing archive /var/cache/apt/archives/solc_1%3a0.3.6-nightly-2016-08-10-fh-3fc68da-0ubuntu1~trusty_amd64.deb (--unpack):
trying to overwrite '/usr/lib/libsolidity.so', which is also in package libethereum:amd64 1.2.9-SNAPSHOT--20160630-f09ff00~trusty-0ubuntu1
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Errors were encountered while processing:
/var/cache/apt/archives/solc_1%3a0.3.6-nightly-2016-08-10-fh-3fc68da-0ubuntu1~trusty_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

It appears that the recent nightly build broke a dependency with libsolidity.so in libethereum...

Does this make sense and is anyone else having this problem?

Comments

  • cbenedictcbenedict Member Posts: 2
    When I do:
    
    sudo apt-get -o Dpkg::Options::='--force-overwrite' install cpp-ethereum
    I can get the install to work (after removing and autoremoving cpp-ethereum)

    I get messages in the log confirming that libsolitity.so was overwritten.

    Selecting previously unselected package solc:amd64.
    Preparing to unpack .../solc_1%3a0.3.6-nightly-2016-08-10-fh-3fc68da-0ubuntu1~trusty_amd64.deb ...
    Unpacking solc:amd64 (1:0.3.6-nightly-2016-08-10-fh-3fc68da-0ubuntu1~trusty) ...
    dpkg: warning: overriding problem because --force enabled:
    dpkg: warning: trying to overwrite '/usr/lib/libsolidity.so', which is also in package libethereum:amd64 1.2.9-SNAPSHOT--20160630-f09ff00~trusty-0ubuntu1
    dpkg: warning: overriding problem because --force enabled:
    dpkg: warning: trying to overwrite '/usr/lib/liblll.so', which is also in package libethereum:amd64 1.2.9-SNAPSHOT--20160630-f09ff00~trusty-0ubuntu1
Sign In or Register to comment.