Error while building C++ client on Windows

Hi All,

I'm trying to build the c++ client locallay, and I get following error when compiling LibQEthereum.vcxproj

c:\_\ethereum\cpp\Qt\Src\qtdeclarative\include\QtQml/QtQml(3): fatal error C1083: Cannot open include file: 'QtQml/QtQmlDepends': No such file or directory [c:\_\ethereum\cpp\cpp-ethereum\windows\LibQEthereum.vcxproj]

I used VS2013 and the bootstrap.sh script from the deveolop branch, and followed the instructions from this page: https://github.com/ethereum/cpp-ethereum/wiki/Building-on-Windows

Anyone an idea where file should be located? I did a quick search and couldn't find it.
Any feedback appreciated.

Tim

Comments

  • teoteo Member Posts: 4
    Sorry man, no idea. But Since you started this thread I'd like to add another error.

    Using Windows 8.1 64bit and compiling following the instruction at https://github.com/ethereum/cpp-ethereum/wiki/Building-on-Windows (Compiling with Visual Studio Express for Windows Desktop 2013, 7Zip 9.2.0, Git 1.9.2, Perl 5.16.3, Python 3.4, Ruby 1.9.3). Everything seems just fine BUT I get the following error:

    c:\Users\matteo\boost\boost/concept/detail/msvc.hpp(22): error C2220: warning treated as error - no 'object' file generated (..\libethereum\Instruction.cpp)[c:\Users\matteo\cpp-ethereum\LibEthereum.vcxproj]

    c:\Users\matteo\boost\boost/concept/detail/msvc.hpp(22):warning c4100: 'x' : unreferenced formal parameter (..\libethereum.cpp)[c:\Users\matteo\cpp-ethereum\LibEthereum.vcxproj]

    [...]

    Build FAILED.

    [...] (see picture attached).


    BTW: the link given in the mentioned webpage used in the instruction

    " curl -O https://raw.github.com/ethereum/cpp-ethereum/develop/windows/bootstrap.sh "

    did not worked for me, I used

    " curl -O https://raw.githubusercontent.com/ethereum/cpp-ethereum/develop/windows/bootstrap.sh "
  • teoteo Member Posts: 4
    Ok, now I have the same error of @timcools‌ ... (the otherone being fixed by setting "false" instead of "true" at line 179 of LibEthereum.vcxproj)
  • programmerTimprogrammerTim Member Posts: 4
    Thanks, updated instructions to use the following which should be more robust (pretty sure it worked originally!):
    curl -o bootstrap.sh -L https://raw.github.com/ethereum/cpp-ethereum/develop/windows/bootstrap.sh

    I've disabled the C4100 warning (and fixed another) so develop branch is compiling for me as of revision 246eba286934e6.

    Regarding the missing Qml/QmlDepends, it'd generated during compiling Qt and should live in:
    Ethereum\Qt\x64\qtbase\include\Qml\QmlDepends
    and
    Ethereum\Qt\Win32\qtbase\include\Qml\QmlDepends

    Check there. Might be that Qt didn't compile properly for some reason. If you delete the x64 or Win32 folder and run bootstrap.sh it should compile it again. Building Qt is a barrel of fun, but sadly they don't ship binaries for VS2013 last I checked and VS2013 is the minimum MSVC compiler that'll compile C++11 heavy Ethereum code!

Sign In or Register to comment.