Withdrawing ETH from DAO to a wallet contract

zktpekzktpek Member Posts: 1
I originally sent ETH to the DAO contract from an Ethereum wallet contract, not an Ethereum account. (On the Slock forums it was stated that sending from either was fine.)

When I try to refund using Ethereum Wallet, Mist, and MyEtherWallet, they are expecting an account not a wallet contract, and the wallet contract isn't selectable. When I select the wallet's owner account, Ethereum Wallet/Mist/MyEtherWallet show it as having no DAO. Checking the DAO balance of the wallet contract in www.daohub.org shows DAO in the wallet contract.

I've tried using Geth using the instructions at https://ethereum.stackexchange.com/questions/7204/how-do-i-convert-my-the-dao-tokens-into-ethers-using-the-withdrawal-contract-aft/7205#7205:

I use the Wallet's owner account in the line

geth --support-dao-fork --unlock {your account} console

...and Geth unlocks the Wallet's owner account successfully. (If I use the Wallet contract, Geth returns "Failed to unlock account ... (no key for given address or file)")

I then use the Wallet contract in the "account" variable, but Geth returns "Account locked" when I run this line:

var approve = theDAO.approve(theDAOWithdrawalAddress, theDAO.balanceOf(account), {from: account});

Can anyone help? Thanks


Sign In or Register to comment.