Problems with DAG

IncepatorIncepator Member Posts: 10
I have a gigabyte 7950 3 gb and I tryed some options and can't resolve the problem, it always bails :
Allocating/mapping single buffer failed with: clEnqueueWriteBuffer(-4). GPU can'
t allocate the DAG in a single chunk. Bailing.
clEnqueueWriteBuffer(-38)
Please help me out I am trying for 3 days now... i have catalyst 15.7.1.

Comments

  • verjicverjic Member Posts: 143
    Hello,

    insert this sentences in bat file for starting ethminer:

    setx GPU_FORCE_64BIT_PTR 0
    setx GPU_MAX_HEAP_SIZE 100
    setx GPU_USE_SYNC_OBJECTS 1
    SET GPU_SINGLE_ALLOC_PERCENT = 100


    It should work.

  • IncepatorIncepator Member Posts: 10
    setx GPU_FORCE_64BIT_PTR 0
    setx GPU_MAX_HEAP_SIZE 100
    setx GPU_USE_SYNC_OBJECTS 1
    and --cl-extragpu-mem 0
    This is one of the .bat
    Another one is :
    setx GPU_FORCE_64BIT_PTR 0
    setx GPU_MAX_HEAP_SIZE 100
    setx GPU_USE_SYNC_OBJECTS 1
    setx GPU_MAX_ALLOC_PERCENT 95
    setx GPU_SINGLE_ALLOC_PERCENT 95
    First was 100 then modifyed for 95
    Note that the gpu has 3gb
    Tryed varios setting and bailing every time.
    Now I am trying an older version of catalyst.

  • IncepatorIncepator Member Posts: 10
    Bump! help me out here... No one?
  • dlehenkydlehenky Member Posts: 2,249 ✭✭✭✭
    Try the 15.12 driver. Btw, what miner are you running? What does your command line look like?
  • leetizzleleetizzle Member Posts: 8
    Incepator said:

    setx GPU_FORCE_64BIT_PTR 0
    setx GPU_MAX_HEAP_SIZE 100
    setx GPU_USE_SYNC_OBJECTS 1
    and --cl-extragpu-mem 0
    This is one of the .bat
    Another one is :
    setx GPU_FORCE_64BIT_PTR 0
    setx GPU_MAX_HEAP_SIZE 100
    setx GPU_USE_SYNC_OBJECTS 1
    setx GPU_MAX_ALLOC_PERCENT 95
    setx GPU_SINGLE_ALLOC_PERCENT 95
    First was 100 then modifyed for 95
    Note that the gpu has 3gb
    Tryed varios setting and bailing every time.
    Now I am trying an older version of catalyst.

    Try this, it worked for me:

    setx GPU_FORCE_64BIT_PTR 0
    setx GPU_MAX_HEAP_SIZE 100
    setx GPU_USE_SYNC_OBJECTS 1
    setx GPU_MAX_ALLOC_PERCENT 95

    ethminer.exe -G -F http://127.0.0.1:8080 --farm-recheck 400 --cl-local-work 256 --cl-global-work 16384

    Currently using 15.12 drivers
  • IncepatorIncepator Member Posts: 10
    It's mining now. Thanks!
Sign In or Register to comment.