Problem sending (function) transaction to contract [Fixed - My bad]

KatatsukiKatatsuki Member Posts: 17
edited April 2016 in Mist
I'm trying to execute the changeFee function on my contract. It has an onlyowner modifier. When the account that owns the contract tries to execute the function this happens:

However, other accounts seem to be able to make the same transaction just fine (except it doesn't actually execute):

Why is this caused and how can I fix it? Tried osx and windows wallets 0.5.1 and 0.5.2, same problem everywhere.

I also tried making the transaction through geth like this and also wasn't successful:

myContractInstance.changeFee.sendTransaction(60, {from: eth.accounts[1], to: contractAddress, value: 0, gas: 200000, gasPrice: eth.gasPrice});

Some help would be really appreciated.


  • KatatsukiKatatsuki Member Posts: 17
    Disregard that I'm retarded. I thought I had implemented the fee in 0-100 range, but that was the multipliers. The problem is that I was entering a value that was too high (60 rather than 6).

    And that, kids, is how you waste 2 hours of your life for no reason.
Sign In or Register to comment.