Ethereum on cloud9 issues

nogo10nogo10 Member Posts: 26
I recently hit a snag while installing ethereum on a cloud9 instance (Ubuntu 14.04 ) . I sucessfully installed the Truffle Solidity testing framework. Then I attempted to install cpp-ethereum building from the git ethereum/webthree-umbrella .. There are missing files as shown ..

What I need is either eth or geth client to deploy to testnet and experiment.

cmake ..
.....

-- Could NOT find jsoncpp (missing: JSONCPP_INCLUDE_DIR JSONCPP_LIBRARY)
-- JsonCpp headers: JSONCPP_INCLUDE_DIR-NOTFOUND
-- JsonCpp lib : JSONCPP_LIBRARY-NOTFOUND
CMake Error at webthree-helpers/cmake/UseJsoncpp.cmake:8 (message):
Jsoncpp library not found
Call Stack (most recent call first):
webthree-helpers/cmake/EthDependencies.cmake:105 (eth_apply)
libweb3core/libdevcore/CMakeLists.txt:11 (eth_use)


-- Configuring incomplete, errors occurred!

Comments

  • nogo10nogo10 Member Posts: 26
    edited March 2016
    cont'd

    searching for the missing file in git repo it seems the file is listed in this file:
    dependency_graph/generate.py
    Showing the top match. Last indexed 12 days ago.

    print ' "scrypt"' print ' "secp256k1"' print " }" print ' "base" -> "boost"' print ' "base" -> "Jsoncpp"' <-------------missing file

    EDIT: according to this<a href="https://github.com/ethereum/cpp-ethereum/issues/781"> github issue tracker there was a problem with the jsoncpp lib however issue was closed [?]
    Post edited by nogo10 on
Sign In or Register to comment.