pyethapp wrong network_id error

I use a Mac where I installed geth and was able to compile and run contracts written with solidity. I used pip to install pyethapp some 10 minutes ago using sudo pip install pyethapp --force-reinstall. I am able to create a new user but the moment I run pyethapp run, I get a series of errors like.

WARNING:eth.chainservice invalid network id remote_network_id=996787477 expected_network_id=1
WARNING:protocol protocol exception, stopping error=wrong network_id
INFO:p2p.peer received hello client_version=Gexp/v1.3.2-c880ed18/linux/go1.5 version=4 capabilities=(('exp', 63), ('exp', 62), ('exp', 61))
INFO:p2p.peer received hello client_version=Geth/eth-peer-dal09-3/v1.3.2-54904379/linux/go1.5.1 version=4 capabilities=(('eth', 63), ('eth', 62), ('eth', 61), ('shh', 2))
WARNING:eth.chainservice invalid network id remote_network_id=1661978001 expected_network_id=1

When I run pyethapp run --console this is what I get


At the same time, geth is however able to download blocks and as said before send transactions. What am I doing wrong. I also deleted the pyethapp folder in Library/Application Support.

Thank you in advance for reading this post and helping me to resolve my issue.


  • vijaymukhi712vijaymukhi712 Member Posts: 2
    Finally patience solved the issue. When I use geth, within 30 seconds I start receiving transaction. When however I use pyethapp for 20 minutes ( this happens each time I run pyethapp) all that I see are assertions and hello messages and then the blocks start getting downloaded. Any one can throw some light on why this happens.
Sign In or Register to comment.