Not being able to send ether with geth - Can someone help?

I have geth running on Windows, fully synchronized with the network, when I do a transaction I see the transaction ID in geth but when I check my balance again, it is still the same and the transaction is not in the blockchain at all!

I tried to send transactions of 1 ether in 2 ways:

1. eth.sendTransaction({from: '0x----------------------------------------', to: '0x----------------------------------------', value: web3.toWei(1, "ether")})

2. eth.sendTransaction({from: eth.accounts[3], to: '0x----------------------------------------', value: web3.toWei(1, "ether")})

When I execute both of them the tx ID, but when I recheck my balance, it's still the same!

I check the balance in the following way:

web3.fromWei(eth.getBalance(eth.accounts[3]), "ether")

It's been already hours since I tried the first transaction and still nothing...

Any ideas what's the issue?


  • lverdaslverdas Member Posts: 64
    What I'm doing is pretty much what is here:

    I get the transaction ID as shown there, it just seems the transaction is not being broadcasted to the network?

    It's been already 4 hours since my first transaction and I see nothing on, the balance of the sender account still the same.
  • lverdaslverdas Member Posts: 64
    When I do:

    eth.getBlock("pending", true).transactions

    I see my transaction there.

    But I see nothing on

    Why I see my transaction in the pending? Is this something to do with Gas?

    Can someone help please?
  • Crypt1xCrypt1x The BlockchainMember Posts: 52
    Is your wallet unlocked first?

    Then can you try to follow these steps below. First you can try to set up these variables in geth since it has built-in JS:

    > var sender = eth.accounts[0]; > var receiver = eth.accounts[1]; > var amount = web3.toWei(0.01, "ether")

    First check your wallet addresses and choose the one to set in "var sender" & "var receiver".
    Adjust your "var amount" you would like to send.

    Then type in GETH:

    > eth.sendTransaction({from:eth.coinbase, to:eth.accounts[1], value: web3.toWei(0.05, "ether")})

    You should see the txid.

    Can you paste your txid that you have already please to check it?

    Hope this helps!

    Donations welcome here: 0x875295c182a584748141a1ee7c75cdf990414ca8 ;)
  • lverdaslverdas Member Posts: 64
    all is unlocked, I get the txid already, I think issue is something with the nodes...
  • lverdaslverdas Member Posts: 64
    transaction is not being broadcasted to the network
  • apassapass Member Posts: 1
    lverdas, I'm having the same problem, and I've written [email protected] directly to no response. If you get any insight into this let me know, and I'll do the same.
  • lverdaslverdas Member Posts: 64
    Why there is no support from ethereum devs on this? I still have same problem
Sign In or Register to comment.