download blockchain

descartedescarte Member Posts: 25
i believe the blockchain should be about 8G. I ran geth for 3 days already and I am only at 600000 records. Wondering if there is a way to download a recent blockchain and I can sync from there?


  • dlehenkydlehenky Member Posts: 2,249 ✭✭✭✭
    @descarte : It would be faster to the extent that you wouldn't be processing the transactions, since an up-to-date data-dir archive would have done that already. I would think you would want to get it from someone on the same platform (Windows, linux, etc.) due to differences in pathname and file permission syntax, etc. What are you running? How would someone transfer it to you?

    -Best Care
  • descartedescarte Member Posts: 25
    i thought someone would have exported the blockchain into a file and share in via free online storage. Someone torrented it last year but the filesize was very small then.
  • DPS50DPS50 Member Posts: 79

    I am trying to download the blockchain and it stops after 15min by saying no peers online ...
    Any idea what is wrong ?
    I am running windows 8.1 ...

  • DPS50DPS50 Member Posts: 79
    how can I synchronize it ?
  • dlehenkydlehenky Member Posts: 2,249 ✭✭✭✭
    @DPS50 It means whatever peer/peers were connected to you are no longer connected. Are you running 'geth'? If so, you can type "net.peerCount" at the 'geth' console prompt to see how many peers are connected to you. Do you have port forwarding enabled on your router for port 30303, and your system firewall set to allow that port through? Otherwise you'll get a couple initial "bootstrap" connections, when you start up, but you won't get any p2p connections.

    -Best Care
  • DPS50DPS50 Member Posts: 79
    edited February 2016
    Thanks for the help David
    I download geth v1.3.3
    I unzip it and then i move it to C folder and then i went to CMD and typing CD/
    and then
    geth --rpc

    and it starts to download the blockchain and after 10 min it says sychronisation failed , no peers to download ...

    so I was reading the developers site and that i can write geth --fast
    to force it to download in 20 min,,, does this work ?

    About the port 30303, i didn't do the forwarding yet in the router, i have to do it but it was downloading ..
    the firewall is fine i selected allow ..

    Should I try and older version of geth or do i need the v1.3.3 last version in order to start mining in a pool ?

  • DPS50DPS50 Member Posts: 79
    I open the port and still the same problem ,, is downloading for 5 min and then no peers ... geth --fast
    Any other idea ? what is wrong ?
    is the V.1.3.3 good ?

  • dlehenkydlehenky Member Posts: 2,249 ✭✭✭✭
    @DPS50 : geth 1.3.3 is good; I've been running it for weeks without any problem. I haven't used the '--fast' option, but I'm not sure that's going to help you. Are you sure your ISP isn't blocking or limiting p2p connections or imposing a bandwidth limit?
  • DPS50DPS50 Member Posts: 79
    edited February 2016
    I am using windows 8.1 with panda antivirus and i already set it to let geth.exe to run ... Can you explain me better where to check if the ISP it blocks or limit the bandwidth ?
    I have to close and opening geth.exe every 15min in order to download ...
    now it is in block 475.000 and it has to download till 1024.329
    It's really weird ... i even disable the antivirus and it was the same ..
    thank you
  • dlehenkydlehenky Member Posts: 2,249 ✭✭✭✭
    @DPS50 You'd have to contact your ISP to find out.
  • RolloRollo Member Posts: 2
    Hello, I own the site and I have server capacity enough to support the ethereum blockchain. If there is emand enough I can bring these downloads online weekly. let me know
Sign In or Register to comment.