Local network cluster - transactions are not broadcasting to other nodes

ILethereumILethereum Member Posts: 34
edited February 2016 in Geth - Go Implementation
I'm able to setup a local cluster with two nodes. When I query net.peerCount it returns 2. (although it's bit flaky sometimes the count drops to 0 and again come back automatically)

The issue I have is when I send request to one of the geth node (over RPC port 8545) it doesn't broadcast the transaction to node2 also block number in node2 remains unchanged. So basically the transaction gets confirmed from he receiving node itself. As per my understanding all the nodes should receive the transactions before it's gets confirmed.

Here is the instructions I have followed. https://ethereum.gitbooks.io/frontier-guide/content/cluster.html
Also I wanted to know is there any information available on how to setup a cluster over multiple AWS ubuntu instance running geth.

Any help is greatly appreciated.

Post edited by ILethereum on


  • ILethereumILethereum Member Posts: 34
    I solved it using the tutorial.

    Instead of doing it in one physical machine I tried between two AWS instances. Don't forget to do NTP Synchronization.

    Although I have an observation when I send transaction to one single node it's getting confirmed from that node only which means transactions are not getting propagated to other peers for consensus. Eventually since the blocks are synced so ultimately all the nodes will be aware/query of certain transaction. Not sure if that's working as designed. Please share your thoughts.
Sign In or Register to comment.