[SOLVED] private blockchain - faild enc handshake: could not decrypt auth message

madshellmadshell Member Posts: 3
edited February 2016 in Geth - Go Implementation
I'm trying to deploy a small Ethereum blockchain playground (on EC2 Amazon instances). Installation of Geth is working fine and all my 3 nodes are pinging and telnet 30303 OK between each other. They all have the same genesis.json and geth is running with this command :
nohup geth --identity "MyNode01" --genesis genesis.json --datadir "/home/ubuntu/chain" --port "30303" --nodiscover --networkid 1138 --verbosity 6 console+ &
Here is the error I got on any node when I try to run admin.addPeer('....') :
I0201 15:03:46.675765    3138 server.go:586] Accepted conn [::1]:33147
I0201 15:03:46.697849 3138 server.go:613] inbound conn [::1]:33147 faild enc handshake: could not decrypt auth message (ecies: invalid message)
I0201 15:03:46.697980 3138 server.go:613] static dial conn [::1]:30303 faild enc handshake: EOF
I0201 15:03:46.698059 3138 server.go:465]
It seems the connection is OK but there is some other problem I don't get. What could be the cause?
Post edited by madshell on


  • madshellmadshell Member Posts: 3
    I find out the issue. Indeed, it was the IP address not present in the enode URI. When I'm displaying "admin.nodeInfo", here is an example result:
    enode://280cb677fda3d9dd1ef1751b0dfd1616dad17b813ab855aacd869832649b2c07d[email protected][::]:30303?discport=0
    The IP is not found maybe because of a library problem or a networking issue (I reproduced the problem on 2 MacBook behind a router). Just replacing [::] with the right IP solved my issue.
Sign In or Register to comment.