Issue with Radeon HD 7990 on Ubuntu

gcolbourngcolbourn Member Posts: 48
So I can't seem to get mining to work with my 6GB Radeon HD 7990 on Ubuntu. First of all, when starting eth, it only recognises ~3GB out of the 6GB on the card. I've also tried all 3 drivers - the default, fglrx, and fglrx-updates. When it starts mining, the machine crashes and the screen goes blank (purple or with lines). When testing with the glmark2 benchmark it works ok though:

Any ideas?


  • ethfanethfan Member Posts: 458 ✭✭✭
    Have you installed the AMD APP and ADL libraries?
  • dont12dont12 Member Posts: 60
    It only sees 3Gb at a time, If you install the OpenCL stuff, if you type openclinfo it should show two adapters each with 3Gb, then when you run ethminer it does 25Mhs on each. Careful that card gets hot
  • PTPedroPTPedro Member Posts: 1
    I've been playing with a pair of HD 7990s for a couple of days now. To corroborate what @dont12 said - the reason you only see 3GB is because your one HD 7990 is really two HD 7970s on one card. They each get 3GB of RAM for a total of 6GB on the card. If you list your GPUs with geth or ethminer, you'll see that you show has having two GPUs instead of just one.

    I've had serious problems with these cards overheating very quickly. Has anyone solved that? Did you resort to watercooling?
  • dont12dont12 Member Posts: 60
    I undervalued the card too 1.18V core gets the temps down to 75 for one GPU and 85C for the other, if you run at 1.2V they go over 90C. I believe the card is designed to take it, but I prefer the temps to be cooler, plus I run the fans at 100%. Getting 51Mhs
  • PansyfaustPansyfaust Member Posts: 29
    edited December 2015
    I've managed to undervolt my 7990 to 1.09 (try it, seems to be a golden number for 7990's), and it runs at 1000/1500 quite happily. As a result, with fans speeds never going above 70, my temps stay in the low to mid 70's. Open frame and with aircon though. If you're still having temp issues I found that repasting thermal grease helped reduce temps by around 3 degrees. The stock paste on my 7990 was horrendous, so some MX4 was definitely better.

    Also I know it might be a bit difficult to undervolt in Linux, but I'm in windows and just use Afterburner and I'm set to go.
  • ethfanethfan Member Posts: 458 ✭✭✭
    It is not just difficult to under volt in Linux. It is impossible. I have to use VBE7 (in Windows) then flash the bios to mine under Linux.
  • dont12dont12 Member Posts: 60
    Interesting even at 1.18V the system will freeze after some time, and yes @ethfan I using VBE7 and flashing the bios, since I am using Ubuntu
  • peepeedogpeepeedog Member Posts: 32
    To add on to this, my 7970 Sapphire Black Edition shows up as 1.5GB of memory out of 3GB. I have no idea why the miner only recognizes 1.5GB, but it runs fine and has a hashrate of 23.

    Other people have mentioned that the miner will not start if less than 2GB, so maybe it's just displaying incorrectly but does actually have 3GB.

Sign In or Register to comment.