Ether balance became 0 after executing upgradedb

Hello Everyone,

I am new here so please forgive me if this question is appropriate in this category.
I just started learning about ethereum and already did mining for 3 weeks now.
My existing wallet has a balance of 18 and when I tried to execute manual payout from pool, I have waited 3 hrs for it to be received.
Unfortunately it still didn't arrived in my wallet so I tried upgrading the db in the hope that it might get synchronize using the command below:
geth --datadir "C:\path\to\ethereum\directory" upgraded

I have waited for it to be completed and I terminated the program in the middle due to unexpected issue in my machine.
Then I reexecuted the command and it did complete.

However, when I tried to check my balance, my balance suddenly became 0.
I am in complete total lost now after seeing this.

Is there anyone that can help me if there is any way to recover my balance?
I still have the private key file.

And regarding the manual payout transaction from the pool, it just being sent in my account after 4 hrs and I now see the total balance of my wallet address.
No sent transactions has been executed but still my wallet address displayed 0 when executing the command below:
web3.fromWei(eth.getBalance("hash_address"), "ether")

I hope anyone can suggest how to fix this given that I still have the private key in my pc.

Best Answer

Answers

Sign In or Register to comment.